Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

Anonymous
Not applicable

I'm trying to compile a push2email( link is below) example with WICED studio 6.2.

https://community.cypress.com/community/wiced-wifi/wiced-wifi-forums/blog/2014/12/05/email-state-cha...

These are the steps I did:

  • Downloaded WICED 6.2
  • Downloaded zip file from link above
  • copied files under Apps to a folder- push2email.
  • created a make target(as shown in the image below)
  • executed the make target
  • Causes error but the build finishes

Can anyone help find the solution to this problem.

pastedImage_3.png

Message was edited by: Chris Collins

0 Likes
1 Solution
RaktimR_11
Moderator
Moderator

As the help article is somewhat outdated the library that was used is not a part of the current SDK. You can instead use the gpio_button or button_manager library in the makefile, change the header file accordingly. Alternatively, you can also modify the existing SDK code snippet example snip.email for your use case.

View solution in original post

4 Replies
RaktimR_11
Moderator
Moderator

As the help article is somewhat outdated the library that was used is not a part of the current SDK. You can instead use the gpio_button or button_manager library in the makefile, change the header file accordingly. Alternatively, you can also modify the existing SDK code snippet example snip.email for your use case.

View solution in original post

Anonymous
Not applicable

I have changed it to gpio button but it did not work.

pastedImage_0.png

0 Likes
RaktimR_11
Moderator
Moderator

The header file should be gpio_button.h or button_manager.h (guess there is a typo as seen from your screenshot). Please check 43xxx_Wi-Fi/libraries/inputs to further check the library best suited for your use-case. Even after this, inside the main application, gpio_keypad_enable API is not defined as the library is not present in the current SDK. Please replace that API with your choice of IRQ based implementation or RTOS based implementation. You can also start modifying the snip.email example application if you still get compile errors.

0 Likes
Anonymous
Not applicable

Thank you

0 Likes