Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

EyLa_3227556
New Contributor II

Hi,

I've tried to carefully follow the Amazon FreeRTOS tutorial (https://www.cypress.com/training/using-amazon-freertos-cypress-cyw43907-and-cyw54907 )

When checking out commit dae01094 (dated 2019.07.08) as explained in the tutorial I get the following error message:

MAKEFILE MAKECMDGOALS=demo.aws_demo-CYW943907AEVAL1F-FreeRTOS-LwIP download run OTA2_SUPPORT is disabled

make.exe[1]: *** No rule to make target 'WICED/RTOS/FreeRTOS/../../../../../../vendors/cypress/freertos_thirdparty_port/GCC/Wiced_CY/portmacro.h', needed by 'build/demo.aws_demo-CYW943907AEVAL1F-FreeRTOS-LwIP/Modules/apps/demo/aws_demo/../../../../../../vendors/cypress/boards/CYW943907AEVAL1F/aws_demos/application_code/main.o'.  Stop.

make.exe[1]: *** Waiting for unfinished jobs....

Building Bootloader waf.bootloader-NoOS-NoNS-CYW943907AEVAL1F-P103-SoC.43909

When checking out the tag 202002.00 (commit 987d9697 dated 2020.02.19) I get the following error message

(Same for tag 201912.00 (commit 8add5b91dated 2019.12.18))

MAKEFILE MAKECMDGOALS=demo.aws_demo-CYW943907AEVAL1F-FreeRTOS-LwIP download run OTA2_SUPPORT is disabled

make.exe[1]: *** No rule to make target 'apps/demo/aws_demo/../../../../../../freertos_kernel/include/FreeRTOS.h', needed by 'build/demo.aws_demo-CYW943907AEVAL1F-FreeRTOS-LwIP/Modules/apps/demo/aws_demo/../../../../../../vendors/cypress/boards/CYW943907AEVAL1F/aws_demos/application_code/main.o'.  Stop.

make.exe[1]: *** Waiting for unfinished jobs....

What's goign on here??

Thanks

0 Likes
1 Solution
MuraliR_36
Moderator
Moderator

Hi

This looks like an issue faced during build process, but in the description it is mentioned that the issue was faced during  git check out.

Could you please clarify on this?

Looks like some files were missed out during the git clone. Could you try the steps once again and check?

Also, I followed the same steps as mentioned in the videos and the build went through.

Thanks

View solution in original post

2 Replies
MuraliR_36
Moderator
Moderator

Hi

This looks like an issue faced during build process, but in the description it is mentioned that the issue was faced during  git check out.

Could you please clarify on this?

Looks like some files were missed out during the git clone. Could you try the steps once again and check?

Also, I followed the same steps as mentioned in the videos and the build went through.

Thanks

View solution in original post

EyLa_3227556
New Contributor II

Thanks.

It was indeed a problem with cloning the afr repository.

I had to update the main repo's submodules to make it to work..

Thanks again.

0 Likes