Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

Anonymous
Not applicable

Hi WICED community,

I'm new in the WICED world and I have a non-technical question.

I have started WICED evaluation on a sn8205 evk+ demo board and I discovered that WICED supports two rtos/stack couple (freertos/lwip and threadx/netx).

I have somes problems when I'm using the appliance demo with freertos/lwip when scanning for AP in the configuration mode. The webpage (scan_page_outer.html) does not reply on my smartphone (a wiko ozzy based on android 4.2.2). With ThreadX/Netx, there is no problem, the discovered APs are displayed.

So my question is to know if the ThreadX/NetX broadcom license is only for evaluation or if I can use them in a commercial product ?

Thanks for your reply,

Best regards

0 Likes
1 Solution
SeyhanA_31
Employee

Hi,

You can use ship your product with ThreadX/NetX license from Broadcom as long as you are using the Broadcom connectivity chip.

For FreeRTOS issue on the appliance demo I will check it.

Seyhan

View solution in original post

0 Likes
9 Replies
SeyhanA_31
Employee

Hi,

You can use ship your product with ThreadX/NetX license from Broadcom as long as you are using the Broadcom connectivity chip.

For FreeRTOS issue on the appliance demo I will check it.

Seyhan

View solution in original post

0 Likes
Anonymous
Not applicable

Hi Seyhan,

Thanks for your reply.

Let me know if you need more details to reproduce the issue or if you need debug trace or whatever.

0 Likes
SeyhanA_31
Employee

Hi,

Did you update the appliance app then it fails or out of the box fails? If you have updated the application, please share your update that triggers the failure. Feel free to send me your changes as a private forum message.

Seyhan

0 Likes
Anonymous
Not applicable

Hi Seyhan,

No, I did not update the appliance app. The only modification which I made are :

1. Apply the Murata patch (WICED-SDK-3.1.0_SN8xxx_IDE.patch)

2. Apply the LwIP patch (WICED 3.1.2 Fix for FreeRTOS with LwIP)

3. Create a target named : demo.appliance-SN8205x-FreeRTOS-LwIP download run

4. Build the new target and run it

I am able to connect to the WICED Config AP but when I click on the Wi-Fi Setup button, nothing happened (neither with my smartphone nor with Chrome under a windows 7 laptop)

Here is the log on SN8205 side :

Starting WICED v3.1.2

Platform SN8205x initialised

Started FreeRTOS v7.5.2

Initialising LwIP v1.4.0.rc1

WWD SDIO interface initialised

WLAN MAC Address : 00:0B:6C:41:A2:14

WLAN Firmware    : wl0: Nov  7 2014 16:03:45 version 5.90.230.12 FWID 01-61489f2c

Starting WICED v3.1.2

Network ready IP: 192.168.0.1

Processing request for: /

Processing request for: /

Processing request for: /config/device_settings.html

Processing request for: /config/device_settings.html

Processing request for: /config/device_settings.html

Processing request for: /images/brcmlogo.png

Processing request for: /images/brcmlogo_line.png

Processing request for: /config/device_settings.html

Processing request for: /config/scan_page_outer.html  ==> click on Wi-Fi button

Processing request for: /

Processing request for: /config/device_settings.html

Processing request for: /

Processing request for: /config/device_settings.html

0 Likes
SeyhanA_31
Employee

Hi,

I have repeated your issue with SDK-3.1.2.

Issue had been already fixed on next release candidate, please wait for next release. I do not know the estimated date of next release yet.

Your application development with Thread-X with NetXDuo should compile and work with FreeRTOS and LwIP.

Seyhan

0 Likes
Anonymous
Not applicable

Hi Seyhan,

We are also using sdk-3.1.2 in our product, so we'd like to know the

root cause and the impact.

Can you elaborate the root cause a bit since you mentioned it is fixed in

next release.

I'd appreciate if you can also post the fix on the forum if possible.

Thanks.

0 Likes
SeyhanA_31
Employee

Hi,

If the appliance application is built with debug option it works as expected. Could you please try the same in your setup?

Seyhan

0 Likes
Anonymous
Not applicable

Err.. I don't get it.

I asked the root cause is because we need to know the impact.

Build with debug option is not an option because we don't release our image

with debug build.

0 Likes
SeyhanA_31
Employee

Hi,

Debug build is for workaround to continue development. It is not suggested for release product.

Once a patch is available to fix this issue, it will be posted on the form.

Seyhan

0 Likes