Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

KoM_2154881
New Contributor II

Hi,

We are using BCM20737S to communicate with another chip using the UART.

We are having this problem where once in a while the received messages are incomplete. It is common that

the middle part of the UART message is missing. It has been verified that the other side is sending the correct message

and that it sends 16 bytes a time until the FIFO is empty.

The only thing that makes sense at this point is that the BLE is not handling the received data right. We are suspecting that

the uart callback is called with a significant delay and thus we have missing bytes.

We don't see any specific patterns, most of the time it works fine until for a small hiccup that would drop bytes and then continue normally.

Do you think that what I am describing makes sense? I have disabled sleep and using lpm_queriable etc.

Also, if that's true is there another way to handle the UART data?

Thank you,

Kostas

0 Likes
3 Replies
AnjanaM_61
Moderator
Moderator

Hi Kostas,

Could you please share the project with us ? Also the steps to reproduce the issue?

Thanks & Regards,
Anjana

KoM_2154881
New Contributor II

I will create a version of the code appropriate for sharing and the steps to reproduce the problem.

Thank you,

Kostas

0 Likes
KoM_2154881
New Contributor II

Sorry for not following up right away with some code.

I run multiple tests on this issue and the problem is apparent when the module receives long messages, more than 80 characters.

It happens sporadically and the buffer is being overrun before calling the callback.

I am pretty sure you can recreate this problem using the uart example in WICED.

Kostas

0 Likes