Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

Hi Sir,

I found a very weird situation about the PUART rx.

I do the experiment to send a continuous packets from Host SoC to BCM20736.

The packet length is 3 bytes only. Once the BCM20736 received the data, it echo the data back to BCM20736.

The following photo are the waveform that the scope with UART module.

The configuration is 115200/8n1. Do you have any idea what's going on?

uart_wave_01.JPG

uart_wave_02.JPG

uart_wave_03.JPG

0 Likes
1 Solution
MichaelF_56
Moderator
Moderator

I spoke with the developers today and they confirmed:

1.

We prefer to see bus speed errors that are +/-2% or less of the configured baud rate, not 5% as noted above.

2.

Unfortunately, this does not exist.

View solution in original post

0 Likes
5 Replies
Anonymous
Not applicable

Hi JT,

This case is different. You can see I'm the guy ask in one of the post link.

1. this is 3 bytes, so, the overflow 15 bytes seems not the case.

2. my interrupt threshold is P_UART_WATER_MARK_RX_LEVEL (1);

    I've changed to 3 bytes, the result is still NG.

3. the sleep mode has been disabled.

I'm wondering if the signal accuracy cause it. Is there any error flag that I can check for puart transmission?

Like frame error or something. Thanks.

0 Likes
Anonymous
Not applicable

The host soc's guarantee +-5% error rate of the uart bus.

Could the BCM2073x receive correctly?

Another thing is I check the puart.h and do not see anything about the error status API.

Is there anyway to check if puart bus encounter overrun/underrun/frame error?

0 Likes
Anonymous
Not applicable

Now I'm sure that this is framing error and I can reduce to only two question.

1. What's the error rate of the UART bus that bcm2073x can bear?

2. An API to get the error flag of UART bus.

0 Likes
MichaelF_56
Moderator
Moderator

I spoke with the developers today and they confirmed:

1.

We prefer to see bus speed errors that are +/-2% or less of the configured baud rate, not 5% as noted above.

2.

Unfortunately, this does not exist.

View solution in original post

0 Likes