IMPORTANT: Cypress Developer Community currently doesn’t allow sign-in to prepare for the upcoming transition. To learn more, check out our announcement.
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

New Contributor

So I've got an application with a GPIF waveform that worked fine in V1 of the libraries but does not in V1.1 or 1.1.1 (although the upgraded libraries fix other issues I had with spi i2c gpio etc.).


The mechanism should transfer data from an out endpoint via an Auto DMA channel to the gpif which transfers out of an 8 or 16bit interface. The GPIF is running at 50MHz, Master, and the transition from wait to data out is defined as "(!BUSY)&(DMA_RDY_TH3)" where busy is an external input pin. The DMA is receiving data and filling buffers but the consumer CY_U3P_PIB_SOCKET_3 doesn't take any data. I beleive this is because the DMA_RDY_TH3 flag is never asserted having observed it on an output pin, the same is true of the WM flag or the current thread flags, none seem to toggle which they do from builds with V1 library. I have tried using this DMA as a manual channel and commiting the data manually using the CyU3PDmaChannelCommitBuffer function which returns success but I still get no data transferred out of the GPIF or any flags changing state.


Has anyone had this issue or possibly hit on a solution.

1 Reply
Not applicable

Meanwhile, I would recommend you to create a tech support case so that one of our engineer will work on this in parallel to help you.




sai krishna.