Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

doju_4424416
New Contributor

We built our own boards using FX3. I connected my PC and FX3 via USB, but the driver won't come up to my PC. The circuit diagram is the same because it is referenced to the EVM board. PMODE is set to USB Boot. I know that romboot is basically in there. Why can't the USB side connect? I checked the power supply. The 19.2 MHz clock does not work because the USB is not plugged in.

0 Likes
1 Solution
YangyangC_06
Employee

No, the crystal circuit is required to provide clock to FX3 and then FX3 could work on that.

Looks like the clock circuit doesn't work as expected. Could you please check it on your side?

View solution in original post

0 Likes
4 Replies
YangyangC_06
Employee

Please refer to AN70707 first to check if you do something wrong in hardware design.

https://www.cypress.com/documentation/application-notes/an70707-ez-usb-fx3-fx3s-hardware-design-guid...

0 Likes
doju_4424416
New Contributor

I've given the CVDDQ an Lchoke 3.3V, but the reason Crystal doesn't work is because the FX3 hasn't booted?

0 Likes
YangyangC_06
Employee

No, the crystal circuit is required to provide clock to FX3 and then FX3 could work on that.

Looks like the clock circuit doesn't work as expected. Could you please check it on your side?

View solution in original post

0 Likes
doju_4424416
New Contributor

I found the cause. Incorrectly used crystal parts. The crystal I used is NX2520SA-19.2M-STD-CSW-5. I made a stupid mistake. Thank you for your reply.

0 Likes