Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

USB EZ-PD Type-C

Anonymous
Not applicable

I'm unable to make UART serial communication with CX3. I tried UartLpRegMode example. When I single stepped through my code with a J-link segger debugger, I realized that rxTxByte is always zero and apiRetStatus is 69. I'm not getting anything on the serial terminal when I set to the baud rate I configured in the program. Tried putting some CyU3PDebugPrint statements, but nothing is getting printed. Even, after configuring the UART. Tried shorting TXD and RXD pins to see any loopback, but no improvements. Even manual values are not getting printed. I'm not sure, whether I'm running properly and testing.  Any suggestions would be greatly helpful. Thanks for helping !

0 Likes
1 Solution
Anonymous
Not applicable

Hi,

How are you sending the bytes to FX3's rx? Make sure the device that send the bytes configured to the same baud rate?

Also, DebugPrints will not work in this code, as UART is used for serial communication here.

Regards,

- Madhu Sudhan

View solution in original post

0 Likes
1 Reply
Anonymous
Not applicable

Hi,

How are you sending the bytes to FX3's rx? Make sure the device that send the bytes configured to the same baud rate?

Also, DebugPrints will not work in this code, as UART is used for serial communication here.

Regards,

- Madhu Sudhan

View solution in original post

0 Likes