Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

Smart Bluetooth

Anonymous
Not applicable

Something has changed in W7 since I last used this.  I'm not sure which update is responsible .  It seems that the OS no longer performs discovery when adding a ble device and requires some sort of driver in order to see anything other than the GATT Server, 'Find Me' and Proximity services.

Screenshot_032415_094233_AM.jpg

WsOtaUpgrade.exe bombs because it can't find any devices with the service:

Screenshot_032415_094047_AM.jpg


Can anybody point me to information on how to get it to recognize the BCM OTA profile so I can get some boards updated?

0 Likes
1 Solution
Anonymous
Not applicable

This was an easy one....

I had a second, non BCM dongle connected to my computer.

View solution in original post

0 Likes
3 Replies
Anonymous
Not applicable

This was an easy one....

I had a second, non BCM dongle connected to my computer.

View solution in original post

0 Likes
MichaelF_56
Moderator
Moderator

Thanks for letting us know you figured this out Jose.

0 Likes
Anonymous
Not applicable

I initially assumed that the computer was using a second dongle but that one wasn't powered -- I have a 7-port hub with switches to flip devices on and off.  The black on black contrast made the 2nd dongle practically invisible so I didn't see it at first and I assumed that that was the culprit when I finally did spy it.

Close, but no cigar.

It turns out that something on my laptop is causing the on-board BT radio to turn on at boot, even though I have it explicitly turned off via the Lenovo Wireless Radio Manager.  I never saw this behavior before so I assume it's due to some recent update.  Laptop is a Thinkpad T440.

Moral of the story is:  Check your device manager entries before posting a plea for help on the forums!

0 Likes