Announcements
IMPORTANT: Cypress Developer Community currently doesn’t allow sign-in to prepare for the upcoming transition. To learn more, check out our announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

Smart Bluetooth

Anonymous
Not applicable

Hi forrest.chien, mwf_mmfae and j.t,

Here is a new question. Sometimes I got "too much data offset" What is the limitation of the OTA image size?

(Currently ours is about 24K bytes.)

Thanks.

0 Likes
1 Solution
Anonymous
Not applicable

Hi @j.t,

If I used the perrapp of WsOtaUpgrade in SDK 2.1.1. all works well. The problem came the OTA application in SDK 2.2.2. If I click "Start" one more time, it will 100% happened. There should be some problem about the Windows application in SDK 2.2.2

BTW, the 24K OTA bin works well with WsOtaUpgrade in SDK 2.1.1.

Thanks.

View solution in original post

0 Likes
3 Replies
Anonymous
Not applicable

Here is the message looks like:

Too much data offsets:24240 + 40 total:24286 len:20

0 Likes
Anonymous
Not applicable

Hello Henry,

1.  Have you changed the OTA sample App?  It should work and never send too much data.

2.  Your "Too much data..." message - We assume that this is from the Windows Console?

3.  The OTA Image size depends on several things:

     a.  For OTA to succeed you need enough storage space, both RAM and Non-Volatile.

     b.  if you have 64K of EEPROM you need to reserve half of this memory for your image.

     c.  OTA also depends on your available RAM.

4.  The way OTA Upgrade works is:

    a. It sends the size of the image first and then starts sending bytes.

    b.  If the device receives more than the initial bytes that was sent to it, the device will not be able to store the extra bytes

5.  So the answer to your question is not a straightforward answer.

At 24K, you are probably exceeding the limit.

Hope this helps

JT

0 Likes
Anonymous
Not applicable

Hi @j.t,

If I used the perrapp of WsOtaUpgrade in SDK 2.1.1. all works well. The problem came the OTA application in SDK 2.2.2. If I click "Start" one more time, it will 100% happened. There should be some problem about the Windows application in SDK 2.2.2

BTW, the 24K OTA bin works well with WsOtaUpgrade in SDK 2.1.1.

Thanks.

View solution in original post

0 Likes