Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

Public Archive

Anonymous
Not applicable

Hi everyone,

   

we are using spansion nand flash(S34ML01G100T1000) on our custom board interfaced with DM385 processor, and with the ipnc_rdk for the software.

   

i am trying to detect the nand flash from u-boot without any luck. (objective is to implement nand boot), the procedure used here is trying to read the device id of the nand from u-boot, if successful will in-turn conform the communication between the nand and processor.

   

when i try to print maf_id & dev_id i'm getting 0x17 & 0x17. and i'm getting No NAND device found in uboot.

   

am i doing anything wrong, if yes please correct me.

   

can you guys kindly guide me with relevent documents or forum links which will help me understand how exactly the nand is made accessible from the u-boot.

   

thanks in advance for your valuable time and help.

   

Regards,

   

Nishil.

0 Likes
3 Replies
AlbertB_56
Employee

Hello Nishil,

   

There may be the possibility that the  S34ML01G100T1000 may not be fully supported on the TI DM385 processor.

   

However, I will confirm with the Ecosystem Group to verify.

   

 

   

Best regards,

   

Albert

   

Cypress Technical Support

0 Likes
Anonymous
Not applicable

Hi @Albert Braceros,

   

even i'm facing the same issue i have already posted in the forum but no reply,

   

http://www.cypress.com/forum/nand-flash/s34ml01g1-nand-device-not-detecting-uboot-kernel

   

can you confirm whether S34ML01G100T1000 will be supported with TI DM385 processor or not.

   

we are at critical stage of the project so if you can tell us as soon as possible it will be better.

   

Regards,

   

Ganesh

0 Likes