Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

Anonymous
Not applicable

 Can I change UART Component's baud rate at runtime by Application Programming Interface?

0 Likes
7 Replies
Bob_Marlowe
Expert II

The UART is driven by a clock. when you use a prescaler (timer) you may freely change the baud-rate.

   

Are you working on PSoC 1,3, 4 or 5?

   

 

   

Bob

0 Likes
Anonymous
Not applicable

 PSoC5LP. UART version is 2.30. Is it nesessary to set "Clock Selection" to "External Clock"?

0 Likes
ETRO_SSN583
Esteemed Contributor

If you want to control baud rate use external clock. Note you do not

   

have to use timer as clock has APIs you can use to control it.

   

 

   

Regards, Dana.

   

 

   

0 Likes
EvPa_264126
Valued Contributor II

 Hi, Ольга.

   

I have a small project with comments in Russian. I hope it helps you.

   

it here:                       http://mylab.wmsite.ru/moi-razrab/cypress-psoc/

   

UART_Cogfig_Device.zip      http://mylab.wmsite.ru/ftpgetfile.php?id=99

   
    Удачи )))   
0 Likes
Anonymous
Not applicable

 Thank you very much!

0 Likes
Anonymous
Not applicable

Hi every body,

   

I'm doing a project with PSoC1 CY8C24123A, PSoC designer 5.4, using user modules: UART, Counter8 (determine frequency for UART).

   

Contents of project:

   

- PSoC receive data from another module.

   

-Then, PSoC send data to PC via RS232.

   

-Change UART baud rate while PSoC running (When receive data, baud rate is 4800; then send data, baud rate is 9600) (which I want at this project).

   

If I don't change baud rate, receiving data or sending data (baud rate is 4800), PSoC run well, data rerults are good (OK).

   

If I change baud rate when PSoC running (change baud rate by Counter8), no data rerults or once data results (then there are no data results). I don't why about my problem! Can you check my project, please? Is it correct?

   

Many thanks!

0 Likes
Bob_Marlowe
Expert II

When you attach your project's archive, do NOT use chrome, forum software woun't accept that, use ie instead.

   

 

   

Bob

0 Likes