Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

WaMa_286156
Contributor II

  PSoc Creator 4.1 ships without Digital Output Pin version 2.5.  This was available in PSOC Creator 3.0 and 4.0.  This causes designs loaded into 4.1 to fail.

   

 

   

I tried filing a case, but it was closed immediately.  An email said I had to go to the support community, but the "support" link in the community page points back to the mycases which get canceled and an email is generated telling you to go to the support community to file a case which gets canceled and causes an email to be sent which tells you to......

0 Likes
1 Solution
Roy_Liu
Moderator
Moderator

cy_pins_v2.5 is an older version than v2.10 and the latest v2.20, because the 5 is less than 10/20.Component version is defined major.minor model, not decimal numbers.

Anyway, the latest version Creator 4.1 update 1  has a new feature called Web-Based Content Delivery, which should be able solve the problem.

Roy Liu

View solution in original post

0 Likes
5 Replies
Bob_Marlowe
Expert II

So why don't you update all the components of your project to latest?

   

 

   

Bob

0 Likes
WaMa_286156
Contributor II

Ah, you haven't transitioned between PSOC Creator versions lately using the latest versions of stuff.

   

v2.5 is the latest for the pin.  I had to backdate to v2.2 of the pin using creator 4.0, then move back to 4.1.  I believe this to be an oversight on the part of the packagers.

   

One problem was 4.1 did not give me the opportunity to "update to the latest," as it has in the past, it just ripped out the pin and put it into a square, with no notification of where it was connected.  Very disturbing.

0 Likes
Bob_Marlowe
Expert II

I frequently open projects from forum visitors with outdated components. Up to now a component update has always cured these issues. Only exception so far were self-made components which had to be updated first (before updating the project)

   

 

   

Bob

0 Likes
WaMa_286156
Contributor II

That has also been my experience in the past.

0 Likes
Roy_Liu
Moderator
Moderator

cy_pins_v2.5 is an older version than v2.10 and the latest v2.20, because the 5 is less than 10/20.Component version is defined major.minor model, not decimal numbers.

Anyway, the latest version Creator 4.1 update 1  has a new feature called Web-Based Content Delivery, which should be able solve the problem.

Roy Liu

View solution in original post

0 Likes