Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC Creator & Designer Software

Kevin_Lo
Employee

Hi Everyone,

Our customer was using generic DAPLINK hardware along with PSoC programmer 3.27.3 to program their own PSoC6 custom PCBA.

Working without issue until updated to 3.28.x which failed to access the PSoC6 with the same set of hardware worked with 3.27.3.

We would like to confirm if the backward compatibility for DAPlink (old?) is removed since PSoC Programmer 3.28.x

pastedImage_2.png

pastedImage_0.png

Thanks and Regards,

Kevin

0 Likes
1 Solution
DheerajK_81
Moderator
Moderator

Most likely it is related to new and changed transport algorithms in PP3.28 for KitProg3 and MiniProg4 support. Besides the older transports, we test MiniProg3/4, KitProg1/2/3 and ULINK2, but we do not test other hardware with PSoC Programmer. So we cannot comment on this since we don't test with this.

Please use the software provided by the generic DAPLink hardware if any.

Regards,

Dheeraj

View solution in original post

0 Likes
3 Replies
DheerajK_81
Moderator
Moderator

Can you please provide a screenshot of DAPLink mode being able to program in PSoC Programmer 3.27.3? I tried to test on both the versions 3.27 and 3.28 and was unable to program. Please provide more information on the hardware and the steps to recreate your error.

Regards,

Dheeraj

0 Likes
Kevin_Lo
Employee

Hi Dheeraj,

When I using PSoC Programmer 3.27.3 with the same hardware set, I have no problem for accessing the PSoC6 on customer board with the DAPLINK.

pastedImage_0.png

attached photo of the DAPlink which is similar to generic DAPLINK with a USB2.0 Hub+ PL2503 +STM32F103

pastedImage_7.png

Thanks and Regards,

Kevin

0 Likes
DheerajK_81
Moderator
Moderator

Most likely it is related to new and changed transport algorithms in PP3.28 for KitProg3 and MiniProg4 support. Besides the older transports, we test MiniProg3/4, KitProg1/2/3 and ULINK2, but we do not test other hardware with PSoC Programmer. So we cannot comment on this since we don't test with this.

Please use the software provided by the generic DAPLink hardware if any.

Regards,

Dheeraj

View solution in original post

0 Likes