Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6 MCU

Anonymous
Not applicable

The BLE installed in PSoC 4 is BLE 4.2 and The BLE installed in PSoC 6 is BLE 5.0.

So, I care whether they can communicate with each other.

Can PSoC 4 BLE and PSoC 6 BLE connect and communicate with each other?

Best Regards

0 Likes
1 Solution
ShipingW_81
Moderator
Moderator

Yes, PSoC 6 BLE is 5.0 complaint, and as per BLE 5.0 Core Specification, 5.0 low energy devices will be compatible with 4.2, 4.1 and 4.0 BLE devices.

View solution in original post

0 Likes
1 Reply
ShipingW_81
Moderator
Moderator

Yes, PSoC 6 BLE is 5.0 complaint, and as per BLE 5.0 Core Specification, 5.0 low energy devices will be compatible with 4.2, 4.1 and 4.0 BLE devices.

View solution in original post

0 Likes
Top labels