Announcements
IMPORTANT: Cypress Developer Community currently doesn’t allow sign-in to prepare for the upcoming transition. To learn more, check out our announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1

Anonymous
Not applicable

 I have psoc 3 cy8ckit001development kit. I have installed psoc creator version 2. After building the project,when i try to debug, the select target device window does not display any device at all even though i have connected it through USB. Can anyone tell me what i'm doing wrong? I have selected the correct device in the device selector window which is cy8c3866axi-040. Please help.

0 Likes
12 Replies
ETRO_SSN583
Esteemed Contributor

Some things you can try -

   

 

   

1) Reboot system

   

2) Under windows device manager uninstall driver, unplug USB, plug it in again

   

3) Under windows device manager uninstall driver, unplug USB, reboot, plug it in again as system powers up

   

3) Sounds wacky, but I have a system that if I use front facing USB connections, instead

   

of back panel USB connections, it does not operate properly, even though front USB connections

   

work with other devices.

   

 

   

Regards, Dana.

0 Likes
Bob_Marlowe
Expert II

Aren't there two USB-connectors on the Kit-001? Make sure you use the correct one.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

To debug the project on KIT-001, you would need to use Miniprog3 and not the on board USB port. There is no on-board programmer/debugger on KIT-001 like there is one on KIT-030 and KIT-050.

   

 

   

To reiterate, you should connect a miniprog3 to the 10 pin debug port on the porcessor module through the ribbon cable in order to debug the program on CY8CKIT-001.

0 Likes
ETRO_SSN583
Esteemed Contributor

Thanks QS for bailing my rear out on this one, I am so used to thinking

   

about -030, -050, I forget about the -001........

   

 

   

Regards, Dana.

0 Likes
Anonymous
Not applicable

 Your setup should be like this -> Power -001 Kit using 12V adaptor -> Connect MiniProg3 to the PSoC3 processor module via JTAG cable -> Connect the USB cable between one end of MiniProg3 to PC's USB port.

   

 

   

You should see that Windows is trying to install the driver for the MiniProg3 if it is connected to that port for the first time. If you want to confirm whether appropriate driver is installed or not, go to device manager and under USB, you should see MiniProg3.

   

If you are able to see that, then open PSoC Programmer/Creator and try to program. If you get any error message, attach that here.

   

If you are not able to see the proper driver getting installed, then follow the steps mentioned in this KB article - http://www.cypress.com/?id=4&rID=45812. Instead of pointing to FTK driver as explained in the KB article, point to mprog3 driver inside the PSoC Programmer installed location.

0 Likes
Anonymous
Not applicable

 I have connected the miniprog3 and the driver was detected in the device manager.I got the following error message 

   

There was an error running port acquire. There may be no devices attached or a device may be in use by another application.

0 Likes
Bob_Marlowe
Expert II

I had a long fight with that errormessage until I found a solution for me. Closing all programs, re-installing Cypress-software and a bunch of re-bootings, nothing seems to work for me.

   

Then I decided to clean up the USB-dependencies that have been collected so far through the lifetime of my computer. I installed some free software to manage USB devices (See attached picture), then (IMPORTANT!) detached my USB-Connections and de-installed most of the collected devices (I left the USB-Hubs, my keyboard, mouse etc)

   

After a reboot and fixing some of the errors I made, I attached the miniprog3 ... and lo! it worked again!!!

   

I hope this will help you too.

   

 

   

Happy re-booting

   

Bob

0 Likes
Anonymous
Not applicable

 I tried re-booting, alas doesnt work !!

0 Likes
Anonymous
Not applicable

 Why don't you try opening a Tech support case from www.cypress.com/go/support ?

0 Likes
Anonymous
Not applicable

is cy8c3866axi support for usb hub

0 Likes
Anonymous
Not applicable

 i need to read and write files from pendrive using cy8c3866axi usb2.0, i dont know do to R/W please anyone help me

0 Likes
HeLi_263931
Honored Contributor II

@citti: please don't hi-jack existing threads with new question. This thread has nothing to do with your question, so it is unlikely someone helps you here. (Apart from that, it is just several months old). So please open a new thread, with an appropriate subject.

   

Thanks!

0 Likes