Announcements
IMPORTANT: Cypress Developer Community currently doesn’t allow sign-in to prepare for the upcoming transition. To learn more, check out our announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1

JaSi_1632926
Contributor

Hello,

   

I have a CY8CKIT-059 prototyping kit. I'm trying out the CE95277 ADC and UART example project and it works as expected on Windows. However, Linux doesn't seem to be able to enumerate the USB UART:

   
     [438313.531136] usb 1-3.4: new full-speed USB device number 59 using xhci_hcd
[438313.621579] usb 1-3.4: New USB device found, idVendor=04b4, idProduct=f139
[438313.621581] usb 1-3.4: New USB device strings: Mfr=1, Product=2, SerialNumber=128
[438313.621582] usb 1-3.4: Product: Cypress KitProg
[438313.621583] usb 1-3.4: Manufacturer: Cypress Semiconductor
[438313.621584] usb 1-3.4: SerialNumber: 0E0A0338012E4400
[438313.624378] hid-generic 0003:04B4:F139.0006: hiddev0,hidraw3: USB HID v1.11 Device [Cypress Semiconductor Cypress KitProg] on usb-0000:00:14.0-3.4/input0
[438313.625096] cdc_acm: probe of 1-3.4:1.2 failed with error -22
   
   

 Any idea on what causes this?

   

Thanks, Jacob

0 Likes
1 Solution
AnkitaS_51
Employee

Linux is not a supported platform for PSoC Creator and PSoC Programmer as mentioned in the release notes  on page #11 and link-

   

http://www.cypress.com/file/318921/download

   

http://www.cypress.com/documentation/software-and-drivers/psoc-programmer-3245

View solution in original post

0 Likes
4 Replies
AnkitaS_51
Employee

Linux is not a supported platform for PSoC Creator and PSoC Programmer as mentioned in the release notes  on page #11 and link-

   

http://www.cypress.com/file/318921/download

   

http://www.cypress.com/documentation/software-and-drivers/psoc-programmer-3245

View solution in original post

0 Likes
himam_31
Employee

Hello,

   

Which version of Kitprog are you using? Can you please update the kitprog version to the latest and then test this?

   

Thanks,

   

Hima

0 Likes
DaKo_463136
Contributor

Hello,

I face the same issue. Mine is KitProg Version 2.21 (the latest I could get) on a CY8CKIT-044. I would love to get the USB-UART functionality on Raspbian / Ubuntu etc.

The trouble is, the P7.1 (PSoC 4M UART TX connected to PSoC 5LP programmed as Kitprog) is not even on the expansion connectors.

Thank you,

David

0 Likes
DaKo_463136
Contributor

I just solved the issue regarding CY8CKIT-044. There is no connector for PSoC 4 P7.1, but this pin is connected to the PSoC's 5LP P12.6 and this pin is on an expansion connector near the PSoC 5LP.

Anyway, If I could connect the kit directly to USB and get UART data from PSoC 4, that would be great. My workaround is an FTDI cable.

David

0 Likes