Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1

AnA_4675486
New Contributor II

Hi,

I have a PSoC CY8C5888AXI-LP096 in my design which I'd like to flash it using an external host controller. Currently I'm having an issue with "Enter bootloader" command. I try to send '0x01 0x38 0x00 0x00 0x39 0x00 0x17' but I don't get any response back from PSoC. I'm sure that PSoC is reset before sending this command. The checksum settings in the bootloader app is basic summation.

p.s. I followed instructions in https://www.cypress.com/file/45171/download

Thanks,

0 Likes
1 Solution
VenkataD_41
Moderator
Moderator

Hi,

Can you please explain more about your set-up? Have you tried bootoading with Bootloader host tool (along with USB-UART bridge) to confirm that the issue doesn't lie at PSoC 5 side?

Can you please attach the scope waveforms if possible?

The successful scope data for UART bootloading will be like the file attached. Please install Salear logic to view that file.

Logic analyzer software from Saleae

Thanks

Ganesh

View solution in original post

0 Likes
1 Reply
VenkataD_41
Moderator
Moderator

Hi,

Can you please explain more about your set-up? Have you tried bootoading with Bootloader host tool (along with USB-UART bridge) to confirm that the issue doesn't lie at PSoC 5 side?

Can you please attach the scope waveforms if possible?

The successful scope data for UART bootloading will be like the file attached. Please install Salear logic to view that file.

Logic analyzer software from Saleae

Thanks

Ganesh

View solution in original post

0 Likes