Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1

prbh_3338016
Contributor

i AM TRYING TO REBUILD THE RTD EXAMPLE OF PSOC3_4 FOR PSOC5LP KIT BUT MY RTD READINGS ARE NOT PROPER DUE TO IDAC NOT SOURCING PROPER 1MA CURRENT.

i TRIED 1MA SOURCING IN DIFFERENT EXAMPLE OF IDAC8 OF 5LP . HERE IT WORKS FINE BUT IN RTD EXAMPLE IDAC JUST SOURCE 0.22microamps and not 1ma.

please help as this is weird situation

0 Likes
1 Solution
Vasanth
Moderator
Moderator

Hello Pratik,

I have tested the project as per your configuration on CY8CKIT059 kit. I have kept break points during Reference resistor measurement and RTD resistance measurement and I was able to see ~1mA current on both the pins using the multimeter. So the issue at your side might be something else. Could you please tell keep a breakpoint after the IDAC value is set and tell me the voltage at these pins? Your schematic says you are connecting less value resistnaces- so that should not be the issue. Otherwise if you exceed the headroom voltage of the IDAC, you will not be getting the required current. I just wan to confirm that too.

Best Regards,
VRS

View solution in original post

0 Likes
16 Replies
Vasanth
Moderator
Moderator

Hello Pratik,   

Could you please give more details about the issue? If you could share your project that will be helpful. If you haven't made any changes to the RTD example code, please let us know about your RTD external circuit.


Best Regards,
VRS

0 Likes
prbh_3338016
Contributor

Dear vrs,

I am using same example of rtd given in psoc creator . My connection are

also same nothing changed.

For testing of idac I tried running idac8 example . In this example I get

1ma . I verified it using ampmeter. But the rtd example having some weird

issue.Only this example instead of sourcing 1ma it is sourcing 225

microamp only. This makes my rtd reading faulty.

No changes made by me same code same connection only 3 wire rtd is used

0 Likes
Vasanth
Moderator
Moderator

Hi Pratik,

Could you please share your project. In creator go to file -> Create workspace bundle and choose minimal option. Also let me the external circuit diagram of your setup.

Best Regards,
VRS

0 Likes
prbh_3338016
Contributor

Ok . I am currently not at my desk I will do it asap

0 Likes
prbh_3338016
Contributor

DEAR VRS ,

Here is the code attached . circuit diagram hand drawn attached. sorry for

delay and hand drawn circuit diagram.

0 Likes
prbh_3338016
Contributor

board and device is cy8c5888LTI-LP097

0 Likes
Vasanth
Moderator
Moderator

Hello Pratik,

The project you have attached is using part number CY8C5868AXI-LP035 , but the device you have posted is CY8C5888LTI-LP097. I just want to know the pins you are using and schematic so that I can test it at my end. That is why the exact project you are using is required. Additionally are you using CY8CKIT-059 for this testing ?

Best Regards,

VRS

0 Likes
prbh_3338016
Contributor

Dear VRs,

yes i am using CY8CKIT-059 for my project. Also i re-chosen the device from

device selector CY8C5888LTI-LP097 and then compiled.

Details of pins usage

pins 3.6 and 3.7 are sourcing current.

pins 0.0 and 0.1 are reading rtd similarly pin 0.4 and pin 0.5 are

reading ref resistor.

I was just cross testing the project schematic and found that current mux

not properly working here. will please re check at your end.

0 Likes
prbh_3338016
Contributor

Dear Vrs,

This is weird issue. As i have designed and tested many other modules of my

project on this kit59. Some how this code is not working . Also is my 3

wire rtd connection proper. I think it is

On Wed, Sep 5, 2018 at 3:23 PM pratik bhagat <quadratechinfo@gmail.com>

0 Likes
Vasanth
Moderator
Moderator

Hello Pratik,

From a  quick review, can you change pin 0.4 to some other pin( avoid using pins 0.4,0.3,0.2 and 3.2 as they are pins where SAR ADC bypass capacitor is connected). Please let me know whether this solves your issue.

Best Regards,
VRS

0 Likes
prbh_3338016
Contributor

no success.

0 Likes
Vasanth
Moderator
Moderator

Hello Pratik,

I have tested the project as per your configuration on CY8CKIT059 kit. I have kept break points during Reference resistor measurement and RTD resistance measurement and I was able to see ~1mA current on both the pins using the multimeter. So the issue at your side might be something else. Could you please tell keep a breakpoint after the IDAC value is set and tell me the voltage at these pins? Your schematic says you are connecting less value resistnaces- so that should not be the issue. Otherwise if you exceed the headroom voltage of the IDAC, you will not be getting the required current. I just wan to confirm that too.

Best Regards,
VRS

View solution in original post

0 Likes
prbh_3338016
Contributor

Dear vrs,

Thanks for helping me.out.

I followed the said breakpoints and was able to Catch the error.

The ref resistor reading error. Dunno something wrong. I changed the

resistor .

Yes the 1ma current was previously also passing through rtd and ref

resistor and being rapidly switch, and because of this I was not able to

see it on meter.

Thanks a ton problem solved.

0 Likes
Vasanth
Moderator
Moderator

Hello Pratik,

Happy to know that this worked. Happy designing !

Best Regards,
VRS

0 Likes
prbh_3338016
Contributor

Thanks and good bless you

0 Likes
prbh_3338016
Contributor

here is attached code and circuit digram. sorry for delay and hand drawn circuit diagram

0 Likes