Announcements
IMPORTANT: Cypress Developer Community currently doesn’t allow sign-in to prepare for the upcoming transition. To learn more, check out our announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1

Anonymous
Not applicable

Looks like I have a 'ghost' wire in my project. Normally when the schematic has an identical error on a wire, it does not finalize the build.

   

The strange thing here is that the project builds and works fine, and when trying to find the error in the schematic it does not highlight 'red'  when I double click the error.

   

I tried removing all wires, drew a box around the area, and deleted that area.  Made the connections again, but still that fake wire lives somewhere in the project. 

   

Is there a more advanced way to lookup where that fake wire should be?

0 Likes
1 Solution
4 Replies
Bob_Marlowe
Expert II

I has this error two times already. Only cure was to create a new project and using copy&paste filling it with the original code and layout.

   

 

   

Bob

0 Likes
CoMa_264751
New Contributor II

Hi,

   

I have found that when I have been running Creator 4 for some time especially with a large build and some sleep sessions on a PC laptop that  I will get to a stage that when rewiring a schematic that I get a whole lot of errors that will not go away.

   

I have found that if I save the project, close Creator and then restart Creator and open the project again that the errors have disappeared.

   

This tends to make me think that there is a memory leak in Creator 4 ?

   

Never had this with earlier versions of Creator but my projects were a lot smaller smaller at that time.

0 Likes
VlYe_281166
New Contributor II

Still exists in the latest release!

0 Likes