Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

Hello,

   

  I have been following the EP56061 tutorial guide in trying to get the PSoC 5 (CY8CKIT_014) to communicate with UART HyperTerminal. I had followed the exact instruction of the guide and used the PmodRS232 (RS232 converter) connected to the RS232 port and wired it directly to J2 & J3 header. Unfortuately, I am not able to see the result through the Hyperterminal and I would like to know what is it that I am missing because I have all the specs and configurations correct. Please help! Thanks!

0 Likes
11 Replies
Anonymous
Not applicable

Hi Doacn,

   

 

   

Here are some of the tips you can try out.

   

 

   

1) CY8C-014 has P0[0-7], P4[4-7], PP6[0-7], P12[2,3,6,7] exposed at the back as header. So, in the project please use the pins for Rx and Tx in .cydwr 'Pins' tab from amongst the above mentioned pins.

   

 

   

2) Please make sure that the voltage level of PmodRS232 and the CY8C-014 are compatible (both being 5V or 3.3V).

   

 

   

3) The connections should be cris-crossed, that is, the Rx of PSoC should be connected to the Tx of PC and vice versa.

   

 

   

Let us know if it helps.

0 Likes
Anonymous
Not applicable

Hello DASG,

   

  I had followed your tips.

   

1. For Rx, Tx and ADC pins are all in P0[0-3] so that is set up already.

   

2. For the voltage level of PmodRS232 and CY8C-014, I had both of them connect together and verified the voltage level through the mulitmeter and they both came up with the same voltage at 3.2V.

   

3. The connections are cris-crossed with Rx of CY8C-014 = Tx of PmodRS232 and Tx of CY8C-014 = Rx of PmodRS232. 

   

These are checked and verified and I still received no results through the hyperterminal.  

   

Please take a look at the coding that I obtained with the tutorial.

0 Likes
Anonymous
Not applicable

Hi Doacn,

   

 

   

I was able to program the first touch kit with the project associated with EP56061.

   

There were no changes made to the project and the pin selection.

   

The Rx, Tx and Ground pins were connected to the pins of USB- UART converter. Rx to Tx and Tx to Rx (Criss-cross). Not to forget, the Common Ground has to be connected.

   

 

   

AN external potentiometer is used which was varied and the varying value can be seen on the HyperTerminal when "s" was typed through keyboard.

   

The snap-shot below shows the case when the pot was set close to 0.913V.

   

Since, Vref is 2.5V, the expected value is 0.913 x 65,535 / 2.5 = 23,934 counts. The ADC is configured for 16-bit resolution.

   

 

   

0 Likes
Anonymous
Not applicable

I was able to test out the project on both the First Touch Kits, CY8CKIT-014 for PSoC5 and CY8CKIT-003 for PSoC3.

   

In both the cases, I was able to get the output.

   

When any character other than "s" or "S" was entered, a message was sent out through UART "Press S to get ADC data". This is how the code has been written.

   

 

   

   

 

   

Can you please tell more about your hardware setup used?

0 Likes
Anonymous
Not applicable

Hello DASG,

   

  For the hardware set up, I have the RS232 cable connected to the port and the RS232 converter. Then I have the wires connected from RS232 to header of CY8KIT-014. The wires are connect as following

   

RS232 converter                CY8KIT-014 header

   

  TX                                                 RX (P0_0)

   

  RX                                                TX (P0_1)

   

  GND                                            GND

   

  VCC                                             VDDIO

0 Likes
Anonymous
Not applicable

Thanks for your help. We had finally figured out the issue. It was a defective RS232 and we had replaced a new one and it works well. If I had known!!

   

Thanks!!

0 Likes
Anonymous
Not applicable

You're welcome

0 Likes
Anonymous
Not applicable

Hi DasG,

   

i am facing a problem while receiving at RS485 ,Transmitting part is working fine but receiving side its receiving but different

   

i mean to say ,when i transmit  'r' it show #

   

i used below code

   

DIR_Off; // whenreceiving RE and DE bit of RS485 need to low
        j=UART_cGetChar();
            if(j>0)
            {
            DIR_On; // when transmitting RE and DE bit of RS485 need to high
            UART_PutChar(j);
          
            }

   

help in this issue my device is Cy8C22545 AXI 44 pin TQfn

   

 

   

Regards

   

Habib

0 Likes
alli_264371
Contributor

Where can I find on example project with DMX512 or least UART module?..

   

"EP56061.zip" Google not find at all exept that page, UART module I can find datasheet only...


I cannot confirm email and add messages due to a bug on your site, the email section is not active
0 Likes
Bob_Marlowe
Expert II

I really would like to help you, but I do not understand your question correctly.

   

If you need an example project for PSoC5:

   

Start createor 2.0, open a new project with a/your PSoC5 chip. Right-click on the UART-module (in the component catalog under "communication")  and select "Find example project", then follow the instructions given.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Hi maagalex,

   

 

   

The example project is which you are looking for is attached in the forum post here.

   

For additional project, as Bob has already mentioned, you can get the sample project from Creator.

0 Likes