Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

Dear all,

   

 

   

We have been testing a batch of PSOC3 (Silicon ID : 0x1E01E069) and 4 out of 12, we were not able to program them. The error tha we get is the 103. We have tried solving the issue by lowering the frequency of the SWD with no succes.With the PSoC programer, we are able to read the contents of the flash memory, and erase it. But, as you can see in the image, we can not program.

   

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

After looking around, we have found that when we can not program, and get the error 103, when we check the Revision of the chip it always says UNASSIGNED, but, when the PSoCs work, their Revision is PRODUCTION. Does this mean it is a silicon problem? (It can be seen in the images attached)

   

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

 

   

Is there any way of solving it?

   

 

   

Thanks!

0 Likes
4 Replies
HeLi_263931
Honored Contributor II
        This looks like you should file a support case with Cypress. Go to Login/Mycases (on the top right). This shoiuld be faster than asking here, because it seems like only Cypress can answer this. But it would be nice if can post the result here though...   
0 Likes
Bob_Marlowe
Expert II
        I would suggest you to create a MyCase to get into contact with a Cypress engineer. To do so, use "Support & Community -> Technical Support -> Create a MyCase"   
   
Bob   
0 Likes
Bob_Marlowe
Expert II
        Two people, one way for a solution...   
   
Bob   
0 Likes
Anonymous
Not applicable
        Opening it now. I'll post the solution here.   
0 Likes