Announcements
Community Announcement : Welcome to the NEW Cypress Developer Community.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4

Anonymous
Not applicable

Hi,

we developed an application with the module CYBLE-212020-01 and it works fine. Now we tried to use with an Iphone X that has a BLE 5.0 but it doesn't works.

We use in our application the BLE 4.2 custom profile, profile role server, gap role peripheral and security level authenticathed pairing with encryption. It's possible that the systems are not compatible?

Regards.

Giuseppe

0 Likes
1 Solution
Anonymous
Not applicable

Hi Giuseppe,

Our BLE 4.2 devices work with IphoneX, we haven't encountered any issues in this aspect.

Please let me know the issue you are facing and if possible provide a project which replicates the issue.

Also please update BLE component to latest version for all your projects and test the same.

Thanks,

Ranjith

View solution in original post

0 Likes
2 Replies
Anonymous
Not applicable

Hi Giuseppe,

Our BLE 4.2 devices work with IphoneX, we haven't encountered any issues in this aspect.

Please let me know the issue you are facing and if possible provide a project which replicates the issue.

Also please update BLE component to latest version for all your projects and test the same.

Thanks,

Ranjith

View solution in original post

0 Likes
Anonymous
Not applicable

Hi Ranjith,

we updated the BLE component to the latest version and now it works fine with Iphone X.

Thank you very much.

Best Regards.

Giuseppe

0 Likes