Announcements
Community Announcement : Welcome to the NEW Cypress Developer Community.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4

Anonymous
Not applicable

Hi people.

I am at my Wits end here.
I have used these devices in projects at university without any issue.
Right now I'm trying to get one to work with my personal laptop for my current project and I am getting nowhere!

I've spent the last 3 days reinstalling all Cypress software on the computer, trawling the forums, watching the tutorial videos (Which always just breeze past where my problems are), and reading the documentation.

I've tried 2 Psocs, to ensure it isn't broken and yes I am pressing the bloody button.
The device shows up in device manager as 'USB-Serial (Single Channel) Vendor MFG'

and also 'usb serial adapter' but never as a com port. The device is visible in the serial configuration utility, and apparently programmable, yet never visible to any other cypress software, including the bootloader host.

I thought that the PSOC4 could elegantly solve a specific problem I'm having with a very particular project and I was really excited about working with PSOC again but after all of this stress I'm considering using something else. I'm not sure I'm willing to take the risk of producing thousands of units containing 8 Psocs each if I'm having this much trouble just uploading a basic bit of code! 

0 Likes
4 Replies
rola_264706
Honored Contributor II

Are you holding the button all the time while you are plugging it into the USB Port? Is the Blue LED blinking quickly? When you open the bootloader host do you see the device in the window of the bootloader host? As you have two devices it seems strange that both of the devices have and issue but they could.  see this Using the CY8CKIT-049 to Program Another PSoC® 4 - KBA93541 | Cypress Semiconductor

0 Likes
SrikanthD_56
Employee

Click on the Filters button in the Bootloader Host tool and enable the Show USB Device option. See if the Bootloader Host tool lists the kit now.

Filter.png

0 Likes
GeonaP_26
Moderator
Moderator

Hello Jamie,

The USB-Serial device acts as a USB-UART bridge for the CY8CKIT-049-4xxx development kit. Have you tried to change the default settings?

Do you want to use any other configuration controls such as GPIO, SPI, and I2C that use the Cypress vendor driver on the PC? If yes, please make use of section: 'Additional Features of the USB-Serial Device' of http://www.cypress.com/file/141306/download

Best Regards,

Geona Mary

0 Likes
Anonymous
Not applicable

So it turns out this was due to an enumeration problem.

In device manager I had to show hidden devices and manually uninstall AND DELETE (This is crucial unless you want to reboot your machine every 5 bootloads or so) the drivers corresponding to all of the 'ghost' COM port devices, as well as the 'usb-serial vendor MFG' devices which appear under universal serial bus controllers.

At this point PSOC will once again recognise the device. Sometimes you may have to do this repeatedly, but for some reason I haven't had to do this for a few days (not complaining).

Also take note that if you, like myself, are toying with other USB programmable devices such as arduino Bootloader host likes to toy with your baud rate for no apparent reason sometime and set it to 9600!