Announcements
Community Announcement : Welcome to the NEW Cypress Developer Community.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

Anonymous
Not applicable

Hello Cypress Community!

   

 

   

I am working with a PSoC 4200 BLE kit and trying to use 2 SCB blocks to configure 2 different UART connections. I want to have one be TX+RX and the other simply be TX. 

   

 

   

I am having quite a bit of difficulty getting them to work.

   

 

   

Is it possible to have 2 UART connections?

   

 

   

Thanks 

0 Likes
1 Solution
ETRO_SSN583
Esteemed Contributor

Yes, can you isolate problem by getting one to work, then disable

   

it, get the other to work, then turn them both on ? Try initially at

   

low data rates to make sure this is not an overrun problem or in-

   

ability to handle composite traffic, eg. empty fifos on time, etc..

   

 

   

Regards, Dana.

View solution in original post

0 Likes
2 Replies
ETRO_SSN583
Esteemed Contributor

Yes, can you isolate problem by getting one to work, then disable

   

it, get the other to work, then turn them both on ? Try initially at

   

low data rates to make sure this is not an overrun problem or in-

   

ability to handle composite traffic, eg. empty fifos on time, etc..

   

 

   

Regards, Dana.

View solution in original post

0 Likes
Anonymous
Not applicable

I got one to work at the desired baud rate but when adding the second it just follows the other. I have the pins defined and the ports on my computer correct too.

0 Likes