Announcements
Community Announcement : Welcome to the NEW Cypress Developer Community.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

Anonymous
Not applicable

Hi,

   

I am playing with PSoC 4 Pioneer KIT, however always hard to program, hard to find any target in PSoC creator; although there is KitProg USB-UART in device manager.

   

BTW, it is such a long time to program, too slower than Arduino.

   

Just to ask, is that only me have this problem? Or PSoC 4 programming can only work so slow like this?

   

Thanks

0 Likes
13 Replies
ETRO_SSN583
Esteemed Contributor

BTW, it is such a long time to program, too slower than Arduino.

   

 

   

By this you mean compile time or FLASH programming time ?

   

 

   

Regards, Dana.

0 Likes
Anonymous
Not applicable

Flash Programming time

   

I need to restart PSoC Creator 3.3 whenever there is any changes in my project, or PSoC Creator cannot find my PSoC 4 KIT, not to mention flash programming.

   

And even if it has found it, the flash programming time is so long that it appears like the computer crashed.

0 Likes
Bob_Marlowe
Expert II

This is a bit unusual. I would suggest you to de-install and then re-install Creator 3.3. What operating system are you using?

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Windows 7

   

I just had a test, and it took me more than 20 seconds to program.

0 Likes
Anonymous
Not applicable

I am working on UART, and whenever serial port has been closed after opened, PSoC Creator just could not find target again.

   

Even if I plug out PSoC 4 KIT and plug in again, it doesn't work

0 Likes
Bob_Marlowe
Expert II

A Clean & Build for a project using just an UART and some LEDs takes inclisive programming of a pioneer kit 35 seconds.

   

What seems unusual are your problems with the UART. Can you tell us exactly which pins you use on your -042 Kit and how you interface your PC or upload a workspace bundle to have us checked your project.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Hi Bob,

   

It is nice to see you answering questions from almost everyone in this forum. Thank you!

   

I just uninstalled PSoC Creator and reinstalled it, but did not help. I kind of used to the slow programming speed and the time for PSoC Creator to look for a target.

   

But here comes another problem,

   

In the example of SCB_UartComm, which I never change anything, there is no echo; I tried a lot to fix it with delay function or if sentance, however, it seems like UART_UartPutChar() can barely work.

   

Can you help me test that example working in PSoC 4?

   

Thank you!

0 Likes
Anonymous
Not applicable

It seems that the UART_UartPutChar() command in PSoC 4 is waiting for something to give a push; there is no echo at all, however, whenever I reset the board, the echo word comes out right before "Hello World", the initialization sentence.

   

Does that mean, there is something wrong with the board?

   

Thanks

0 Likes
Anonymous
Not applicable

It took me 48 seconds for PSoC Creator to find my debug target since I connected PSoC 4 KIT to my PC.

   

That feels like a century without drinking my coffee.

0 Likes
Bob_Marlowe
Expert II

Post your complete project here, so that we all can have a look at all of your settings? To do so, use
Creator->File->Create Workspace Bundle (minimal)
and attach the resulting file.

   

Meanwhile check your KitProg (integrated on the Pioneer Kit) is up-to-date:

   

Close Creator

   

Start PSoC Programmer 3.23.1

   

Verify your KitProg is shown under the ports and select it

   

click on "Utilities"-tab and select "Upgrade Firmware"

   

 

   

Bob

0 Likes
Bob_Marlowe
Expert II

... and?? Any changes???

   

Please reduce the UART speed to 9600 baud as recommended, adjust PuTTY port accordingly.

   

Update the components, UART has changed.

   

ch should be uint32,, main() should be int.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

No changes, not faster.

   

And in the original example of UART inside PSoC Creator, the codes are same with what you said; it doesn't work so I changed a little bit.

   

Actually, I need the speed to be as fast as possible, and the communication speed through UART is 115200, which is received in a Qt terminal class I wrote; like I mentioned, qt can receive the echo after I reset the board, while Putty cannot; UART_UartPutString works very well, while UART_UartPutChar need a push like UART_UartPutString("\n"). And I need the one byte, 8 bit data in my application.

   

I will change main() to be int.

0 Likes
Anonymous
Not applicable

Thank you!

   

I just upgraded my firmware.

0 Likes