Announcements
Community Announcement : Welcome to the NEW Cypress Developer Community.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

MaMc_3367101
New Contributor II

I've created a fresh project based on the fixed stack Bootloader / Bootloadable projects and have an issue with readable data from the UART TX. I've made sure my UARTs are set for 57600 on both projects and made sure to read at 57600 from my terminal apps(tried multiple, putty, screen). I'm using the included UART debugging code in both projects with the same results. Could my baud rate still be an issue here and if so, how can I calculate or find what my baud rate should be?

I do see data in the terminal but it looks like a baud rate issue no what what baud rate I try. I've tried all preconfigured rates, 9600 - 115200 on both projects and terminal.

screen -L /dev/tty.usbserial-14630 57600

^S/]P]*P\_P^X,,]^P[,1ƣ^S/]P]*P\_EqQ1EQ11QqE^S/]P]*P\_VP1QqEP+]Wc$ODa3fX+bD$1ƣX+bD$1Fƣ

My project settings are all default.

#define DEBUG_UART_ENABLED      (YES)

/* YES - use printf, NO - use UART_PutString

* e.g. DBG_PRINTF("message %d\r\n", i) will transform to UART_PutString("message %d\r\n") */

#define DEBUG_UART_USE_PRINTF_FORMAT  (YES)

0 Likes
1 Solution
MaMc_3367101
New Contributor II

This was a TTL issue. I was using an RS232 cable on a TTL output. Completely my fault but hopefully this helps someone else running into the same issue. TY for your time HimaM_31

View solution in original post

0 Likes
3 Replies
himam_31
Employee

Hello,

Can you please test this with any other terminal like HyperTerminal, Teraterm and check if you are facing the same issue?

Thanks,

Hima

0 Likes
MaMc_3367101
New Contributor II

Yes, I have. I actually believe it's a TTL vs 232 issue now. I'll have the new adapters today to test with and post the result here.

0 Likes
MaMc_3367101
New Contributor II

This was a TTL issue. I was using an RS232 cable on a TTL output. Completely my fault but hopefully this helps someone else running into the same issue. TY for your time HimaM_31

View solution in original post

0 Likes