Announcements
Community Announcement : Welcome to the NEW Cypress Developer Community.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

Anonymous
Not applicable

Hello every one. My first day with CY8CKIT-042. I am trying to follow the very first tutorial which suggests that pressing the second button on chip should trigger the blinking of a red LED. I dont see such a thing. Besides the kit does not connect with the IOS app or the window CySmart 1.2 software. The dongle appears under unsupported targets, and warning says "The current firmware version of the dongle is not supported by the tool. Program the firmware located at <C:\.........\BLE_4_1_Dongle_CySmart_128K.hex> and launch the tool again.

   

Could anybody help me to resolve this. Thanks, Apoorva

0 Likes
1 Solution
rola_264706
Honored Contributor II

Follow there instructions.

View solution in original post

0 Likes
5 Replies
rola_264706
Honored Contributor II

Follow there instructions.

View solution in original post

0 Likes
Anonymous
Not applicable

Thank you so much!

0 Likes
Anonymous
Not applicable

Hi everyone,

   

This is my first time with the pioneer kit, the BLE dongle and CySmart on Windows and I have a similar problem.  On opening CySmart, it appears to see the dongle but it is in the 'Unsupported targets' and instructs me that the current firmware version of the dongle is not supported and to program the firmware located at 'C:\....\Cypress\CySmart\1.2\dongle\CY5670\BLE_4_1_Dongle_CySmart_128K.hex'.  So following the instructions, I've gone into PSoC Programmer, loaded this hex file in the file path and updated the firmware.  Everything appears fine in PSoC Programmer, with the firmware update finished successfully and the KitProg version stated as 2.17.

   

Yet, going back into CySmart, there is no change, still unsupported.  Also, the hex file doesn't appear to have been modified - should it?

   

Would very much appreciate it if someone can help.

   

Thanks, Rich 

0 Likes
Bob_Marlowe
Expert II

The firmware you updated was the internal bootloader.

   

What you still need to update is the program that is needed for the dongle. Consult the kit manual for the hex-file.

   

 

   

Bob

Anonymous
Not applicable

Thanks for your reply. Got it in the end from your reply and from section 3.5.3 in the kit guide.

   

Thanks a lot, Rich