Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

Bluetooth SDK

daba_4649501
New Contributor II

hello,

i am using CYBT-413055-02 module, i configured dual spi mode and both spi are working perfectly. i also need to receive 10 bytes from PUART and i configured PUART  callback function.

then i run the program , dual spi channel working fine but when i enter some data in puart com port(terraterm software), the puart callback function is NOT WORKING.

so i disabled one SPI and run the program in single channel SPI mode and PUART call back function..but this time PUART call back function is WORKING.

is there any limitations for using dual spi and puart callback at the same time?

i am using MODUS TOOL BOX 6.2 and sdk version is <version>2.6.0.7989</version>.

please i need answer for this ASAP.

SaEa_4705941LePo_1062026MaRi_1281436broadcomwiced-adminAnjanaM_61SheetalJ_96

THANKS AND REGARDS,

DANNY.

0 Likes
1 Solution
AnjanaM_61
Moderator
Moderator

Please call the spi_init(); and test_puart_driver(); in BTM_ENABLED_EVT event after initializing the stack using wiced_bt_stack_init .

Stack initialization is needed even for reliable working of peripheral functions.

This should fix the issue.

Regards,

Anjana

View solution in original post

8 Replies
daba_4649501
New Contributor II

hello,

anyone has any update on this one?

MaRi_1281436YuxianL_01SaEa_4705941LePo_1062026broadcomwiced-adminAnjanaM_61SheetalJ_96

0 Likes
Len_CONSULTRON
Honored Contributor II

Danny,

I'm not sure I can help you.   The part you mentioned in your original post (CYBT-413055-02) is not a PSoC base CPU.

Len

Len
"Engineering is an Art. The Art of Compromise."
0 Likes
daba_4649501
New Contributor II

Hello,

Sorry for the inconvenience.

Thanks for the reply.

regards,

Danny.

0 Likes
AnjanaM_61
Moderator
Moderator

Hi daba_4649501 ,

There should not be any issue in using Dual SPI and PUART together.

However I am not sure if there is any issue with latest SDK.

=> i am using MODUS TOOL BOX 6.2 and sdk version is <version>2.6.0.7989</version>.

- There is no MTB 6.2. Can you please confirm if you meant MTB 2.1?

- Which pins are you using for SPI1 , SPI2 and PUART. Did you check if any SPI pins are multiplexed with PUART pins by any chance

- How are you testing the three at same time?

- Can you please share the code , so that we can have a look ?

Regards,

Anjana

daba_4649501
New Contributor II

hello,

sorry about the modustool box 6.2 confusion, its modus tool box 2.1 version that i am currently using.

i have included the device configurator images for your referance .

please note that when i use DUAL SPI the PUART TX pin working fine , that means i can able to see the trace output but cannot able to use PUART RX pin which means PUART callback function  is not working. but when i initialize SINGLE MODE SPI , puart call back function is working fine.

please see the attachment images for DUAL SPI AND PUART pin outs.

Thanks and Regards,

Danny.

0 Likes
AnjanaM_61
Moderator
Moderator

Hi daba_4649501 ,

By pins I don't see any issue.

Are you using a custom board ? If then, did you check if there is any short between any of the SPI lines and PUART by any chance?

If possible, can you provide the test code so that we can try reproducing the issue at our side?

Meanwhile we will check internally if this issue is reproducible.

Regards,

Anjana

0 Likes
daba_4649501
New Contributor II

hello AnjanaM_61​,

Sorry for the delay,

i have attached the test code for the PUART call back problem. please refer the code and get back to me.

Thanks and regards,

Danny.

0 Likes
AnjanaM_61
Moderator
Moderator

Please call the spi_init(); and test_puart_driver(); in BTM_ENABLED_EVT event after initializing the stack using wiced_bt_stack_init .

Stack initialization is needed even for reliable working of peripheral functions.

This should fix the issue.

Regards,

Anjana

View solution in original post