7 Replies Latest reply on Aug 9, 2017 2:08 PM by user_463759797

    Support: MiniProg3 no longer works on VM

    user_463759797

        I tried filing a case, but it was closed immediately.  An email said I had to go to the support community, but the "support" link in the community page points back to the mycases which get canceled and an email is generated telling you to go to the support community to file a case which gets canceled and an email is sent which tells you to......

         

       MiniProg3 no longer works under VMware 8.58, windows 7,  Cypress Programmer 3.26.....

         

       None of the usual work arounds are applicable now in the vmx file:

         

      usb.quirks.device0 = "0x04b4:0xf113  skip-reset, skip-refresh, skip-setconfig"

         

       

         

        KitProg works, but with the latest sofware update, it is 2 to 5 times slower....

        • 1. Re: Support: MiniProg3 no longer works on VM
          anks

          This has been in Release Notes for PSoC Programmer-

             

          Upgrading the KitProg1/KitProg2 firmware in a virtual environment (e.g. “Parallels Desktop” or “VMWare Fusion”) may result in fail during initialization or detection of the Kit as a “Bootloader device” instead of “KitProg” after firmware update. This is because during a firmware update process, KitProg changes the mode from “KitProg” to “Bootloader” and then back to “KitProg”. This changing of the VID/PID of the USB device causes the virtual machine to unplug the Kit from the guest OS. To prevent this issue, use one of the following solutions:

             

          a) Configure the virtual machine to automatically connect all USB devices to the guest OS. b) If automatic connection of all USB devices is not supported, the virtual machine may be configured to connect automatically only the devices with known VID/PID. For the KitProg, switch the Kit into the three different modes successively (“Bootloader”, “KitProg” and “Mass Storage”) and configure the virtual machine to connect the detected devices (in each mode) to the guest OS automatically. c) If the virtual machine does not support such configuration, you need to manually reconnect the Kit after switching from KitProg to Bootloader mode or vice versa.

          • 2. Re: Support: MiniProg3 no longer works on VM
            user_463759797

              Thank you ANKS, but you misunderstood the question.

               

              This was about miniProg3, not about kitprog.  KitProg is working, as I indicated in my question above.  Miniprog3 stopped working.

               

               I downgraded to an earlier version of vmware tools, but that did not help.  The vmware fusion version is 8.5.8

               

              Miniprog3 is still not working.  I think the FX2 inside is not being programmed.

            • 3. Re: Support: MiniProg3 no longer works on VM
              user_463759797

                After a lot of looking and comparing problems others were having, I was able to mostly resolve the issue.  It appears to be a vmware tools problem in vmware fusion 8.5.8

                 

                If you downgrade to the vmware tools 10.0.0.30, you can get the miniprog3 to work.  The download location is here: https://packages.vmware.com/tools/releases/index.html

                 

                Go into the 10.0.0 directory, into windows, and download the iso.  Go to the cd/dvd drive under vmware virtual machine settings and point it to the iso file downloaded.

                 

                Use control panel in the vm to uninstall the current vmware tools, reboot, then install the vmware tools from the cd in windows.  You may have to run setup or setup64 manually.

                 

                 This fixed the miniprog3 problems for the most part. You still have to reconnect manually, using the vmware usb menu after plugging it into your computer, as vmware is not handling reconnect properly at the current time.  It appears to get confused by the fx2 being programmed and then reporting itself as a different device.

              • 4. Re: Support: MiniProg3 no longer works on VM
                user_463759797

                I forgot to add one thing.  On the Macintosh, right click on the vmware icon for your virtual machine, and select "show package contents."  open the Windows 7 Pro.vmx file (or whatever it is named, followed by .vmx).

                   

                Edit with a text editor and change the line

                   

                tools.upgrade.policy = "upgradeAtPowerCycle"

                   

                to

                   

                tools.upgrade.policy = "manual"

                   

                Otherwise your vmware tools will be automatically upgraded the next time you reboot.

                • 5. Re: Support: MiniProg3 no longer works on VM
                  user_463759797

                   One final comment:  Even though I got it to work, it is very spotty.  Sometimes it refuses to work.  Sometimes it works.  

                     

                    It would be nice to be able to use minprog3 because it is faster than the kitprog.  However, kitprog does work, and for that I am grateful.

                  • 6. Re: Support: MiniProg3 no longer works on VM
                    anks

                    Can you tell us what error message are you getting when you try to program via MiniProg3 on PSoC Programmer.

                       

                    This KBA may be useful-

                       

                    http://www.cypress.com/knowledge-base-article/miniprog3-not-working-mac-os-sierra-kba217936

                    • 7. Re: Support: MiniProg3 no longer works on VM
                      user_463759797

                      I just got the round tuit <joke>, and tried it again.  

                         

                      It worked this time.   It gives the error message about the cypress usb device not connecting properly. I then reconnect through the vmware usb menu.  

                         

                       After selecting the debug target in the menu, then clicking on the debug icon, it just took about 20 seconds to start talking to the minprog3.  After that, it programmed the device, and it worked.  And debugged.

                         

                        Did you slow down interraction to the miniprog3 by any chance?