1 Reply Latest reply on Sep 4, 2017 1:28 AM by srdr

    AN65974 Stream In FPGA problems

    content.librarian

      I've been trying to use AN65974, Designing with the EZ-USB® FX3™ Slave FIFO Interface, as an example for my own design.  I've modified the stream out VHDL code for my purposes, but I'm having trouble with the stream in.  In the slaveFIFO2b_streamIN module, even if I simply change the line that sets the data from

         

      data_gen_stream_in <= data_gen_stream_in + '1';

         

      to

         

      data_gen_stream_in <= data_gen_stream_in + "10";

         

      or even just make it a constant and leave everything else the same, the Streamer app fails when I try to do a Stream In.  Looking at the code for the streamer app, it doesn't look like it checks the value of the data.  I've also probed the flags, and they don't look significantly different from when I use the original code.

         

      Can anyone give me some advice about what may be going wrong, or how to debug this?  Is it possible that the VHDL code is less up to date, and I may have better luck with the verilog code?  Is there some other example or documentation that anyone can recommend other than AN65974 that may help me?

         

      Thanks, -Mike 

        • 1. Re: AN65974 Stream In FPGA problems
          srdr

          What is your application? why are you changing the data_gen_stream_in value?

          There should not be any issue, even though if you change it.

           

          Share the screen shots of the streamer when the failure happens?

          Have you enabled Debug Prints, if yes, share them too?

           

          If you have any USB Hardware Analyzer, please take the trace and share with us.

          If you don't have, you can get the same trace with software Analyzer (Bus Hound ).
          BTW,  What is the firmware that you used here? Have you done any modifications to project provided with AN65974?
          Regards,
          Srdr