4 Replies Latest reply on Feb 10, 2017 8:09 AM by droghio Branched to a new discussion.

    Problem with OTA Android

    luftfoto24

      Hi everyone,

      As the title says, I have a problem with OTA. Just for testing it, I took the sample app you can find here  https://community.cypress.com/servlet/JiveServlet/download/9499-5157/OTA_Android_Sample_NoSecure.zip

      The created firmware seems to be fine. I'm able to do the OTA upgrade on Windows with the WsOtaUpgrade.exe.

       

      The app seems to run fine, too. It doesn't throw any exceptions. I have added a small feature: A FileChooserDialog, so I don't have to manually fill in the full path to the binary every time I try to upgrade a device.
      As you can see in the attached image, the correct size of the binary is detected, but the upgrade process is stucked in this "state" (The ProgressBar does nothing). I also tried to get some informations from the debugging print of my smartphone, but I couldn't find anything (Also added as attachment).

       

      Is there a known issue with this app? if yes: how can I fix it up? If no: Is there a working alternative and where can i find it?

       

      Additional informations:

      WICED SDK Version 2.2.3

      Smartphone: Galaxy S4 Mini

      Android Version: 4.4.2 (API 19)

      SoC: BCM20736S

       

      I hope someone has the know-how to help me.

       

      Best regards,

      Miime

        • 1. Re: Problem with OTA Android
          cliff@rayman.com

          luftfoto24

          Can you trace this from the firmware side?  That's how I have found OTA issues previously.  My guess, based on the output you provided, is the Android side is receiving an abort from the firmware.  Of course, once it has done that, it should shut down the window or offer to restart the process.

          1 of 1 people found this helpful
          • 2. Re: Problem with OTA Android
            droghio

            Has there been any update on this? I'm encountering the same issue with Android 6.0 API 23. Still using the API 19 target and everything works fine except that the upload freezes and reports that it failed.

             

            My log looks similar to the above except there is a JAVA failure:

             

            W/BluetoothGatt: Unhandled exception in callback

                             java.lang.NullPointerException: Attempt to invoke virtual method 'void android.bluetooth.BluetoothGattCallback.onConnectionStateChange(android.bluetooth.BluetoothGatt, int, int)' on a null object reference

                                 at android.bluetooth.BluetoothGatt$1.onClientConnectionState(BluetoothGatt.java:228)

                                 at android.bluetooth.IBluetoothGattCallback$Stub.onTransact(IBluetoothGattCallback.java:70)

                                 at android.os.Binder.execTransact(Binder.java:453)

             

            But it looks unrelated to the main upload issue.

            • 3. Re: Problem with OTA Android
              luftfoto24

              Hi everyone and sorry for the late response.

              We have found a solution for the issue. First we've detected an error on the BCM by using the tracing functions. We figured out, that the android sources (https://community.cypress.com/servlet/JiveServlet/download/2011-3093-9499-5157/OTA_Android_Sample_NoSecure.zip) produce a "Bad fw size: Size: 1", so we decide to build a new app including the updated version (https://community.cypress.com/servlet/JiveServlet/download/9499-6616/AndroidOtaSampleCodes_V1.1.zip)

              Now the OTA Upgrade worked in 1 of 10 cases up to ~70%...
              The last idea we had was to downgrade the WICED SDK from 2.3 to 2.1., because the sources were tested with this version by the sources author.

              And this was the solution. Now everything works stable.

              I dont know what is different in the ws_upgrade[...] parts but maybe there should be more easy to find information about these facts or maybe the android sources author should develop an update for the newer SDK version.

              But anyway,

               

              Thanks to cliff@rayman.com
              We hope, that this will help others with the similar problems.

               

              Best regards,

              Miime

              2 of 2 people found this helpful
              • 4. Re: Problem with OTA Android
                droghio

                Good to hear you figured out a patch, any chance you would be willing to post your revised app? I'm trying to test OTA on a few devices and it would be helpful to test against software that is known to work. The stock Broadcom/Cypress OTA upload is a bit temperamental.