3 Replies Latest reply on Nov 15, 2017 11:08 AM by mmalagon Branched to a new discussion.

    BCM43907 Flashing through Uart and JTag

    muralidhar

      If So How to flash binary Through UART instead of JTAG for BCM43907.

        • 1. Re: BCM43907 Flashing through Uart and JTag
          mifo

          The BCM43907 has not been released to the broad market yet, so as such, it is not supported here on the WICED Community.  Please work with the Module Partner (IoT Solutions Guide) or local Cypress Sales/Distribution partner that enabled you with this platform in order to setup the appropriate factory support.

          • 2. Re: BCM43907 Flashing through Uart and JTag
            axel.lin_1746341

            Is there any WICED platform supports flash binary Through UART instead of JTAG?

            • 3. Re: BCM43907 Flashing through Uart and JTag
              mmalagon

              Hello mifo

               

              I have the BCM43907 Module and I'm trying to debug it with the SEGGER JLink probe.

               

              When I compile like this:

              kits.CYW943907AEVAL1F.adc_measure-CYW943907AEVAL1F-FreeRTOS-LwIP-debug JTAG=jlink download

               

              I get the error:

              make[1]: *** [download_dct] Error 1

               

              And I get this output in the openocd_log.txt file:

              Open On-Chip Debugger 0.10.0-dev-00226-g5c6b00b-dirty (2017-08-28-11:10)

              Licensed under GNU GPL v2

              For bug reports, read

              http://openocd.org/doc/doxygen/bugs.html

              none separate

              adapter speed: 100 kHz

              adapter_nsrst_delay: 100

              Info : auto-selecting first available session transport "jtag". To override use 'transport select <transport>'.

              jtag_ntrst_delay: 100

              post_init_43909_setup

              Info : No device selected, using first device.

              Info : J-Link V10 compiled Sep  8 2017 17:24:33

              Info : Hardware version: 10.10

              Info : VTarget = 0.000 V

              Info : clock speed 100 kHz

              Error: JTAG scan chain interrogation failed: all ones

              Error: Check JTAG interface, timings, target power, etc.

              Error: Trying to use configured scan chain anyway...

              Error: BCM43909.cpu: IR capture error; saw 0x0f not 0x01

              Warn : Bypassing JTAG setup events due to errors

              Warn : Invalid ACK 0x7 in JTAG-DP transaction

              Warn : Invalid ACK 0x7 in JTAG-DP transaction

              Warn : Invalid ACK 0x7 in JTAG-DP transaction

              Warn : Invalid ACK 0x7 in JTAG-DP transaction

              Warn : Invalid ACK 0x7 in JTAG-DP transaction

              Warn : Invalid ACK 0x7 in JTAG-DP transaction

              Warn : Invalid ACK 0x7 in JTAG-DP transaction

              Warn : Invalid ACK 0x7 in JTAG-DP transaction

              Warn : Invalid ACK 0x7 in JTAG-DP transaction

              Warn : Invalid ACK 0x7 in JTAG-DP transaction

              Error: Could not initialize the debug port

              force hard breakpoints

              Error: BUG: can't assert SRST

              error: -4

              in procedure 'sflash_write_file'

              in procedure 'sflash_init' called at file "apps/waf/sflash_write/sflash_write.tcl", line 258

              in procedure 'post_init_43909_setup' called at file "apps/waf/sflash_write/sflash_write.tcl", line 160

              in procedure 'reset' called at file "apps/waf/sflash_write/sflash_write.tcl", line 564

              in procedure 'ocd_bouncer'

               

              Could you please help me understand what is going on?

               

              Thanks!