7 Replies Latest reply on Dec 11, 2016 11:23 PM by mmotamarri_2263101

    BCM43340 - wl pkteng_start - Unsupported

    mmotamarri_2263101

      Hello,

       

      Have an issue to generate continuous packet-mode traffic using packet engine with wl utility.

      Below are the driver and firmware version details:

      [root@AT91SAM9 ~]# wl ver

      1.141 RC77.0

      wl0: Mar 11 2014 12:07:36 version 6.10.190.49 (r461234) FWID 01-da477153

      [root@AT91SAM9 ~]#

       

      Running below command to generate continuous traffic:

      wl pkteng_start <mac> tx 300 1500 0

      But the utility returns error as unsupported.

       

      Below is the generated log:

      [root@AT91SAM9 ~]# wl pkteng_start 00:11:22:33:44:55 tx 300 1500 0

      wl: Unsupported

      [root@AT91SAM9 ~]# dmesg -c

      [ 4309.410000] dhd_wl_ioctl: WLC_IOCTL: cmd: 235, ret = -8

      [ 4309.420000] dhd_wl_ioctl: WLC_GET_VAR: fbt_cap, ret = -23

      [ 4309.430000] dhd_wl_ioctl: WLC_GET_VAR: fbt_cap, ret = -23

      [ 4313.680000] dhd_wl_ioctl: WLC_SET_VAR: pkteng, ret = -23

      [root@AT91SAM9 ~]#

       

      It looks like the firmware returns the feature as unsupported.

      Please provide the steps to support this feature. Do i need to use different Firmware for running "pkteng" utility ?

        • 1. Re: BCM43340 - wl pkteng_start - Unsupported
          skerr_1713761

          hi mmotamarri_2263101

           

          Yes.  You need the "mfgtest" firmware.  There should be a "WLTEST" string output when you invoke "wl ver" when checking on driver and firmware versions.

           

          Best Regards,

           

          Scott

          1 of 1 people found this helpful
          • 2. Re: BCM43340 - wl pkteng_start - Unsupported
            mmotamarri_2263101

            Where can I get the mfg test firmware?

            • 3. Re: BCM43340 - wl pkteng_start - Unsupported
              mifo

              I know on WICED, instructions to run manufacturing test on a WICED hardware platform are provided in the WICED Manufacturing Test User Guide located in the SDK's <WICED SDK>/Doc directory.

               

              This references an app that is available within the SDK and compiled/downloaded to the board being tested.

               

              We have a Linux based API guide for the firmware here: https://community.cypress.com/docs/DOC-2378

               

              But I cannot seem to find the actual firmware. I will need to check with others.

               

              skerr_1713761

              • 4. Re: BCM43340 - wl pkteng_start - Unsupported
                vens

                Yes the mfgtest firmware needs to be used for pkteng commands.

                ==

                The mfgtest firmware is part of the tar file attached to this doc.

                 

                Quick Start with iMX6 Ultralite EVK and Mass Market Modules

                 

                The insmod_dhd.sh script has an option to load the firmware using the mfg test firmware.

                 

                more ./scripts/insmod_dhd.sh

                ap_mode=false

                mfg_mode=false

                while [ "$1" != "" ]; do

                        case $1 in

                                -ap   ) ap_mode=true;;

                                -mfg  ) mfg_mode=true;;

                        esac

                        shift

                done

                ...

                ...

                ...

                 

                The mfgtest firmware is located in 43340 directory.

                 

                Venkats-MBP-9: ~/work/bcm/from_community/bcm_imx_08_12_2016/43340 : ls

                43340.hcd bcmdhd.cal bcmdhd.oob.cal fw_bcmdhd.bin fw_bcmdhd_apsta.bin fw_bcmdhd_mfgtest.bin

                3 of 3 people found this helpful
                • 5. Re: BCM43340 - wl pkteng_start - Unsupported
                  mmotamarri_2263101

                  Thank you vens for sharing mfg firmware.

                   

                  I tried the firmware but facing different issue now.

                  Below are the version details:

                  [root@AT91SAM9 ~]# wl ver

                  1.141 RC77.0

                  wl0: Apr 13 2016 02:45:38 version 6.10.190.61 (r631123 WLTEST) FWID 01-3ff1

                   

                  when i run below command for tx traffic i am getting an Undifined error.

                   

                  [root@AT91SAM9 ~]# wl pkteng_start 00:23:a7:7a:b8:98 tx 300 1500 0

                  [  455.600000] dhd_wl_ioctl: WLC_SET_VAR: pkteng, ret = -1

                  wl: Undefined error

                   

                  I have folowed blelow steps:

                  • Loaded mfg fw
                  • ifconfig wlan0 up
                  • wl up
                  • wl mpc 0
                  • wl pkteng_stop <tx>
                  • wl pkteng_start <mac> <tx> <ifs> <frmlen> <nframes>

                   

                  Please find bleow for more information for further debugging.

                  pkteng status is as follows:

                  [root@AT91SAM9 ~]# wl pkteng_stats

                  Lost frame count 0

                  RSSI 0

                  Signal to noise ratio 0

                  rx1mbps 0 rx2mbps 0 rx5mbps5 0

                  rx6mbps 0 rx9mbps 0, rx11mbps 0

                  rx12mbps 0 rx18mbps 0 rx24mbps 0

                  rx36mbps 0 rx48mbps 0 rx54mbps 0

                  rxmcs0 0 rxmcs1 0 rxmcs2 0 rxmcs3 0

                  rxmcs4 0 rxmcs5 0 rxmcs6 0 rxmcs7 0

                  rxmcs8 0 rxmcs9 0 rxmcs10 0 rxmcs11 0

                  rxmcs12 0 rxmcs13 0 rxmcs14 0 rxmcs15 0

                  rxmcs16 0 rxmcs17 0 rxmcs18 0 rxmcs19 0

                  rxmcs20 0 rxmcs21 0 rxmcs22 0 rxmcs23 0

                  rxmcs24 0 rxmcs25 0 rxmcs26 0 rxmcs27 0

                  rxmcs28 0 rxmcs29 0 rxmcs30 0 rxmcs31 0

                  rxmcsother 0

                   

                  wlan status is as follows:

                  [root@AT91SAM9 ~]# wl status

                  [  334.060000] dhd_wl_ioctl: WLC_IOCTL: cmd: 23, ret = -17

                  Not associated. Last associated with SSID: ""

                   

                   

                  [root@AT91SAM9 ~]# ifconfig wlan0

                  wlan0     Link encap:Ethernet  HWaddr 00:AE:FA:BD:C6:87

                            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

                            RX packets:0 errors:0 dropped:0 overruns:0 frame:0

                            TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

                            collisions:0 txqueuelen:1000

                            RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

                   

                  [root@AT91SAM9 ~]# iwconfig wlan0

                  wlan0     IEEE 802.11  ESSID:""  Nickname:""

                            Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated

                            Bit Rate:72 Mb/s   Tx-Power:32 dBm

                            Retry min limit:7   RTS thr:off   Fragment thr:off

                            Power Management:off

                            Link Quality=5/5  Signal level=0 dBm  Noise level=-81 dBm

                            Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0

                            Tx excessive retries:0  Invalid misc:0   Missed beacon:0

                   

                  Am I following proper steps? Are there any configuration steps need to done before running pkteng ?

                  1 of 1 people found this helpful
                  • 6. Re: BCM43340 - wl pkteng_start - Unsupported
                    vens

                    Manoj,

                    Please post this question in a separate thread. Include details of the

                    1) Version of driver your are using.(where you obtained it from). Is it DHD or FMAC?

                    2) Please send logs from the time of loading the driver,including commands which show how you load the driver. Better yet, include the logs from bootup.

                     

                     

                    Thanks,

                    Venkat

                    • 7. Re: BCM43340 - wl pkteng_start - Unsupported
                      mmotamarri_2263101

                      Hi Venkat,

                       

                      I have created a separate thread with debug logs and observations for further discussions. Please follow below link.

                      BCM43340 - wl pkteng_start - Undefined error

                       

                      Thanks,

                      Manoj