0 Replies Latest reply on Oct 25, 2016 8:06 PM by mickael.toumi_1583836

    SmartBridge [BT/Wi-Fi] Application broken on SDK3.7.0-3

    mickael.toumi_1583836

      I believe the SmartBridge Application is broken. I setup a network with a dedicated AP, when the SmartBridge comes up it directly connect to the AP (via the credentials stored in the dct file). I am able to scan BT devices and get a list of BT LE devices via a tablet and a browser connected to the same network/AP. I can also connect to the sensor via the web interface and do the pairing via challenge PIN (using the LightBlue App turning the iPhone into a sensor). I am getting disconnected right after entering the generated passkey.

       

      I have been testing the SmartBridge in the past without issues, I believe there is a fair amount of changes in the latest SDK and something is broken (I will start to investigate, there is a pretty clear log message below).

       

      I tried different EVBs: BCM9WCD5EVAL1_2, ISM43340, I can replicate the issue on all the EVBs.

       

      Logs:

      ....

      [SmartBridge] advertising callback reported

      [App] Scan result

      address:76 1b 90 c8 ec 3c rssi:-35 bdaddrtype:1 event_type:4

      [SmartBridge] Name of Device: TimeDMI_5¨Ð

      [SmartBridge] Received SCAN_RSP

      [SmartBridge] advertising callback reported

      [App] Scan result

      [SmartBridge] Unhandled Bluetooth Stack Callback event :22

      [SmartBridge] Unhandled Bluetooth Stack Callback event :22

      [SmartBridge] LE scan completed.

      [App] Scan complete

      [App] Trying to Connect to Time ...

      [Smartbridge] connect()...socket things are okay

      [SmartBridge] Enable Pairing with Pin: 12345

      [SmartBridge] Paired Device Link Keys Request Event

      [SmartBridge] Paired Device Link Keys Request Event

      [Smartbridge] LE-connect, result:0

      [Smartbridge] GATT connection was SUCCESS

      [SmartBridge] Pairing IO capabilities Request Event

      Getting local I/O capabilities

      [SmartBridge] Passkey Notification event( PassKey generated is: 147742 )

      [SmartBridge] encryption status = 0

      [SmartBridge] encryption status = 0

      [SmartBridge]GENERATING ATT CACHE ...

      [SmartBridge] Discover all Primary Services

      [SmartBridge] Paired Device Link Keys Update Event

      [SmartBridge] Bond-Info updated result: 0

      [SmartBridge] Paired Device Link Keys Update Event

      [SmartBridge] Bond-Info updated result: 0

      [SmartBridge] Service [Start 1 - End 5] uuid:1800 list-count:1

      [SmartBridge] Service [Start 6 - End 9] uuid:1801 list-count:2

      [SmartBridge] Paired Device Link Keys Update Event

      [SmartBridge] Bond-Info updated result: 0

      [SmartBridge] Paired Device Link Keys Update Event

      [SmartBridge] Bond-Info updated result: 0

      [SmartBridge] Pairing complete status=0, reason=0x0.

      [SmartBridge] Service [Start a - End e] uuid:4366 list-count:3

      [SmartBridge] Service [Start f - End 13] uuid:4ae list-count:4

      [SmartBridge] Service [Start 14 - End 16] uuid:1807 list-count:5

      [SmartBridge] Service [Start 17 - End 1b] uuid:1806 list-count:6

      [SmartBridge] Service [Start 1c - End 1f] uuid:180f list-count:7

      [SmartBridge] Service [Start 20 - End 25] uuid:1805 list-count:8

      [SmartBridge] Service [Start 26 - End 2a] uuid:180a list-count:9

      [SmartBridge] Service [Start 2b - End 34] uuid:d0 list-count:10

      [SmartBridge] Service [Start 35 - End 40] uuid:f8dc list-count:11

      [SmartBridge] Discovery Completed ( result:0 type:1 )

      e_att_cache_discover_all, line: 560[SmartBridge] Discovery Completed ( result:0 type:1 )

      [SmartBridge] Error Generating Cache result:8

       

       

      [App] Smartbridge connection executing...

       

       

      [Smartbridge] GATT disconnection