1 Reply Latest reply on Oct 12, 2016 3:55 AM by userc_24369

    7014 Error in tcp_server_async snip

    user_2170816

      Hello,

       

      I am trying to connect Eval. Board via IOS client over TCP and I am using tcp_server_async snip in WICED 3.5.2. I used a Java script, but I m taking 7014 from wiced_tcp_accept() function all the time.

       

      Java script:

      System.out.println("Connecting...");
                  Socket socket = new Socket(host, port);
                  PrintWriter out = new PrintWriter(socket.getOutputStream(), true);
                  BufferedReader in = new BufferedReader(new InputStreamReader(socket.getInputStream()));
                  System.out.println("Connected");
      
      
                  out.print(msg);
                  out.flush();
      
      
                  int chr;
                  int len = 0;
                  while ((chr = in.read()) != -1) {
                      System.out.print((char) chr);
                      if (++len == msg.length()) {
                          System.out.println();
                          break;
                      }
                  }
                  socket.close();
      

       

      Is there any comment or solution for this situation.

       

      Thank you,

       

      Oguz.

        • 1. Re: 7014 Error in tcp_server_async snip

          I tested the snip with the same Java code, in BCM943362WCD4. When I ran the code from Mac OS, it almost never connects to device. I then tried a python script on Windows, this time it connects most of the time but I still see error 7014 around %5 of trials. Also when I get error 7014, I cannot connect to socket again whatever I do(I even tried memsetting socket to 0 and create it again).

           

          One thing I tried was to use NetX instead of NetXDuo. With NetX, it almost connects every time, and the socket is usable after error 7014.