2 Replies Latest reply on Oct 3, 2016 12:50 AM by jesper

    Disable ALL trace output on PUART

    jesper

      I have previously posted this on the Atmosphere forum. Had some suggestions to use Anaren platform files, but it makes no difference.

       

      I'm using the PUART for communication with a micro.
      I've managed to turn off most of the debug output with the BLE_TRACE_DISABLE define.
      However, there are still some data being sent, when I get a connection, for instance, I get a long string of numbers, starting with @$*#.
      Also, at startup, I get "Broadcom Debug Port: CFA Debug".

      How can I turn this off?
      I want only MY data to be sent on the port, not all this garbage.
      I've tried new platform files, I've tried ble_traceDisable(); , ble_traceEnable(0); , ble_traceEnable(2);

      None of this makes ANY difference, I still get the annoying trace output.

       

      -- Smart SDK 2.2.2, OSX

        • 1. Re: Disable ALL trace output on PUART
          BoonT_56

          You may want to try the following:

           

          1) include "sparcommon.h" in your list of header files

          2) include "BLE_APP_DISABLE_TRACING();" in your application_init.

          1 of 1 people found this helpful
          • 2. Re: Disable ALL trace output on PUART
            jesper

            Thank you, that basically solved it, although with a small change.


            The BLE_APP_DISABLE_TRACING macro is disabled, unless the BLE_APP define is set, which it isn't in a Atmosphere export.

            I didn't want to set it, as I don't know what else evil that might enable.
            But, I took the contents of the BLE_APP_DISABLE_TRACING macro and added to my application_init().
            These four lines at the end of application_init killed all the traces (except the initial "Broadcom Debug Port: CFA Debug" at power up, which I don't care about.

             

            extern UINT8 bleapp_trace_enable;

            extern UINT32 blecm_enabledFeatures;

            bleapp_trace_enable = 0;

            blecm_enabledFeatures &= ~(0x04);


            Thank you for the hint!

            1 of 1 people found this helpful