2 Replies Latest reply on Sep 23, 2016 10:34 AM by mifo

    BCM43455 TYPE 1HK evaluation module SDIO card detection problem

    manoj_1578136

      We have successfully tested murata Type 1DX module with am335x evm and  also made our own custom board based on AM335x with Type 1DX module, which was working fine. Now we bought Type 1HK module and I'm using TI am335x EVM for testing and we have added BCM43455 firmware update in to the software.  But with type 1HK module, it is giving problem in wlan card detection.

       

      Working log(type 1DX)

      [    1.654143] mmc1: queuing unknown CIS tuple 0x80 (2 bytes)

      [    1.661149] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)

      [    1.668184] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)

      [    1.676405] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)

      [    1.683411] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)

      [    1.691315] mmc1: queuing unknown CIS tuple 0x80 (6 bytes)

      [    1.779362] mmc1: new high speed SDIO card at address 0001

      [    5.675878] mmc1: queuing unknown CIS tuple 0x80 (2 bytes)

      [    5.704736] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)

      [    5.713073] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)

      [    5.721293] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)

      [    5.821535] brcmfmac: brcmf_sdio_drivestrengthinit: No SDIO Drive strength init done for chip 43430 rev 1 pmurev 24

      [    6.593153] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: May 27 2016 00:13:38 version 7.45.41.26 (r640327) FWID 01-df77e4a7

      [    6.905907] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code

       

      Type 1HK module log

       

      [    1.654089] mmc1: queuing unknown CIS tuple 0x80 (2 bytes)

      [    1.661095] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)

      [    1.668131] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)

      [    1.676349] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)

      [    1.684255] mmc1: queuing unknown CIS tuple 0x80 (6 bytes)

      [    1.740175] mmc1: SDIO_CCCR_IF is invalid: 0xc1

      [    1.744763] mmc1: error -34 whilst initialising SDIO card