2 Replies Latest reply on Feb 2, 2016 6:40 AM by gipec_954681

    Problem with HID off

         

      Hello,

      i'm trying to use HID off (deep sleep) mode on 20737 as neverending sleep, awaking from IO (p3) but the behaviour is not as expected.

       

      1) If I build using the line that configure the pin as pulldown without interrupt, the HID OFF is entered and stays and neverending. On the oscilloscope I see  the pin pulled down to 0 for some microsecond, then it rises slowly up to 0.5 / 0.6V. the consumed current is 2-3 uA, accordingly HID off

       

      2) If I build using the line that configure the pin as pulldown WITH interrupt (on rising edge), the HID OFF is not entered ( the current counsumption stays at 6 mA), the pin remains pulled down to 0 for approximately 5 secs, then it rises up to a step under 1V (like at pw on) then the application restart (after like a sort of reset)

       

      at pw on the pin p3 is configured as pull up.

       

      I have copied the lines here below. The lines related to p3 are as per the case 1.

       


      Many thanks

      for Your help and

      suggestions

       

      // Configure the low power manager to enter deep sleep.

         devLpmConfig.disconnectedLowPowerMode = DEV_LPM_DISC_LOW_POWER_MODES_HID_OFF;
         // Configure the wake time in mS.
         //! \todo [GPez] devLpmConfig.wakeFromHidoffInMs = 13000;
         devLpmConfig.wakeFromHidoffInMs = 0;
         // Configure the reference clock to use.
         // Use the internal source 128k.
         devLpmConfig.wakeFromHidoffRefClk = HID_OFF_TIMED_WAKE_CLK_SRC_128KHZ;

       

         gpio_clearPinInterruptStatus(0, 3);
      //   gpio_configurePin(0, 3, GPIO_EN_INT_RISING_EDGE | GPIO_PULL_DOWN, GPIO_PIN_OUTPUT_LOW);
         gpio_configurePin(0, 3, GPIO_PULL_DOWN, GPIO_PIN_OUTPUT_LOW);

       

         // Enter deep-sleep now. Will not return.
         devlpm_enterLowPowerMode();