4 Replies Latest reply on Mar 4, 2016 10:49 AM by abirjepatil

    AWS IOT certificate and key load error

    aidnani1

      I am using WICED SDK 3.5.2 and was trying out the shadow demo app. However when I provide the certificate and the private key for AWS IOT from the browser (device_settings.html), the browser never completes the second upload.  I have tried uploading the certificate and the key in different order and I always face issues with the upload of the second file.

       

      I am using dev kit BCM943362WCD8.

       

      On further investigation I discovered that the browser doesn't get a response back for the second chunk of the second file. I looked at the demo code and upon some debugging I have narrowed down the problem to writing the security section to DCT. The code never returns from that call. Therefore the response code which is immediately after the DCT write code never gets executed and the browser never gets a response.

       

      Has anyone faced the above issue? How did you solve it?

       

      I have tried erasing the flash (see flash erase result below) with no success in running the shadow app.

       

      > sam4s_flash erase_sector 0 2 5

      sam4 does not auto-erase while programming (Erasing relevant sectors)

      sam4 First: 0x00000002 Last: 0x00000005

      Erasing sector: 0x00000002

      Erasing sector: 0x00000003

      Erasing sector: 0x00000004

      Erasing sector: 0x00000005

      erased sectors 2 through 5 on flash bank 0 in 0.214057s

       

      Thanks

      - Ajay