1 Reply Latest reply on Nov 16, 2020 10:27 PM by YatheeshK_36

    CY7C65215A SPI CDC mode

    user_4768196

      Hi, I have tried to execute the SPI VCP/CDC but it stops at "CySpiReadWrite_VCP" with a time-out error.

       

      There is already an entry in the community, which seems to deal with the same/similar issue (CY7C65211A SPI access ).

       

      What have I done:

      1. I am using the CYUSBS236 USB DVK BOARD

      2. I replaced the CY7C65215 with the CY7C64215A

      3. I have checked the functionality using the "TestUtility" -> I2C/SPI -> OK

      4. I have started with the I2C example delivered with the driver SDK --> OK

      5. I tried to use the SPI example --> FAIL

       

      Any advice on what could be done to get at least the example working?

       

      thx

        • 1. Re: CY7C65215A SPI CDC mode
          YatheeshK_36

          Hello,

           

          I have tested the functionality without any issues.

           

          Can you please let me know if you have modified the application?

           

          Also, please make sure that the below conditions are met:

          1. SCB is configured to SPI CDC Master and the COM port is enumerated in the device manager.

          2. COM port is bound to USB-Serial Port Driver and not USB-Serial Device Driver

          3. Proper jumper settings are made on the DVK,  as per Figure 3-36. SCB SPI Jumpers in CYUSBS236 Kit guide

          4. The correct COM port number is passed as input to the application.

           

          Thanks,

          Yatheesh