10 Replies Latest reply on Nov 16, 2020 12:53 PM by KaHe_4818731

    PSoC 6 101 LED problem

    KaHe_4818731

      Hi there, I am new to development with the PSoC 6 hardware.

       

      I am using a CY8CKIT-062-BLE Rev B and following along with the PSoC 6 101 lessons. I am currently on PSoC 6 101: Lesson 1-3 Hello World. My problem is that the LED will not blink after the board is programmed. I have followed the instructions exactly and have made sure the board is set up. I have gone through the kit datasheets to make sure all the onboard switches are set properly.

       

      Where can I start troubleshooting? I don't know what else I can do here.

        • 1. Re: PSoC 6 101 LED problem
          MoTa_728816

          Hi,

           

          Please refer to the web page of PSoC 6 BLE Pioneer Kit (CY8CKIT-062-BLE)

          https://www.cypress.com/documentation/development-kitsboards/psoc-6-ble-pioneer-kit-cy8ckit-062-ble

           

          In the lower page, there is a table

          001-PLD_Versions.JPG

           

          As you wrote that you are using Rev B, you need to use PDL v3.0.1.

          So you need to change the version of PDL to use.

          In PSoC Creator, you need to select and right-click the project and select Build Settings

          002-build-settings.JPG

           

          In the Build Settings Dialog > Peripheral Driver Library

          the Default is PDL\3.1.2 (in my case).

          So you need to change it to 3.0.1

          003-PDL.JPG

           

          First you need to download PDL 3.0.1 and install from the URL below

          https://www.cypress.com/design-guides/peripheral-driver-library-pdl-software-and-documentation-archive

           

          Then you can do one the following two to select/change the PDL version

          (1) Menu  Tools > Options

          Chnage PDL v3 location from 3.1.2 to 3.0.1

          003-Tools-option.JPG

          (2) Select Custom

          003-PDL.JPG

          004-PDL-Selected.JPG

           

          Hopefully, you can build and use the project after doing above.

          Note: I'm sorry, but as I don't have the board with your revision now, I could not test it in my side.

           

          moto

          • 2. Re: PSoC 6 101 LED problem
            KaHe_4818731

            Thank you.

             

            I have done as you have said and now I get the following errors when building the application:

             

            Additionally I cannot select a debug target:

            I was able to see the debug targets earlier and the programmer does show up in the device manager.

            I checked the PSoC programmer and it seems the kit can no longer be seen:

            The USB connection seems to disconnect unless it it pressed in firmly.

            • 3. Re: PSoC 6 101 LED problem
              MoTa_728816

              Hi,

               

              I'm sorry for hearing that you have more problems now.

               

              From what you wrote I think that you have (at least) 2 problems.

              (1) The project can not be compiled.

              (2) The board can not be detected from the PC.

               

              (1) The project can not be compiled.

              As you have changed the version of PDL, whole intermediate files need to be replaced.

              I would try Clean and Build the project.

              Please try one of the followings

              From menu: Build > Clean and Build <project_name>

              011-Clean-and-build.JPG

              From short cut Icon

              012-Clean-and-build.JPG

               

              If still the compile fails, please attach your project following the instruction below.

              Re: How to attach a project archive file to a question?

               

              (2) The board can not be detected from the PC.

              In the Kit Guide, which you can download from the Kit's web page,

              there are following descriptions.

              I would think that you accidentally pushed either SW3 or SW4,

              most likely SW4. Please try pushing them to change the mode of KitProg.

              010-Kit-sws.JPG

               

              moto

              • 4. Re: PSoC 6 101 LED problem
                LePo_1062026

                KaHe,

                 

                The error about not finding "PWM_Start() usually means it didn't find the component needed PWM in your TopDesign.  Idi you change the schematic circuits in your TopDesign?

                 

                About not finding the debug target:

                Please check the following on your CY8CKIT-062-BLE board:

                • On the main board on the lower left-hand side you will find two switches with four LEDs between them.


                • LED4 and LED2 should be constant on YELLOW.
                • If LED2 is blinking especially at a 2 Hz rate, then you are in the wrong programmer/debugger mode for Creator or the PSoC Programmer to use.
                • If LED2 is blinking press SW3 (KitProg Mode Sw) once.  The LED2 should become constant.  It should now be available to Creator.

                 

                Len

                1 of 1 people found this helpful
                • 5. Re: PSoC 6 101 LED problem
                  KaHe_4818731

                  Okay guys some progress here.

                   

                  I switched the Vbackup/ PMIC control switch on the back of the board to Kitprog 2 and suddenly the Red LED starts blinking every 500ms as it is supposed to. Seems the kit did get successfully programmed on one of my earlier attempts. Now I am still stuck with the problem of not being able to select the target.

                   

                  When I press switch 3 or 4 nothing appears to happen. I am also looking in the PSoC programmer application to see if anything shows there and when I put the board into bootloader mode by holding in button 3 and reconnecting the USB it does go into bootload mode and show up in the PSoC programmer as kitprog2. When prompted to go to utilities and upgrade the firmware I did do so. However when the board resets to normal mode I still cannot see it.

                   

                   

                  What should I be entering in the device family fields? I have tried both the programmer kitprog2 family and the boards PSoC 6 family and I still see nothing to select. 

                   

                  Now for the PWM error it gives me this when I mouse over

                  As for the top design the circuits are built according to the PSoC 101 tutorial

                  • 6. Re: PSoC 6 101 LED problem
                    MoTa_728816

                    Hi,

                     

                    To be able to use PWM_Start()

                    the PWM component needs to be named "PWM" instead of "PWM_1".

                     

                    So you can either

                    (1) Rename the PWM component from "PMW_1" to "PWM"

                    (2) Change PWM_Start()  to PWM_1_Start() ;

                     

                    About the problem of PSoC Programmer can not detected your device,

                    usually this happen

                    (1) The mode of KitProg is wrong. (Similar to the SW3/SW4 topic)

                    (2) KitProg is use by other software, such as PSoC Creator.

                       If you are debugging the board with PSoC Creator

                       PSoC Programmer can not access the board.

                     

                    moto

                    1 of 1 people found this helpful
                    • 7. Re: PSoC 6 101 LED problem
                      LePo_1062026

                      KaHe,

                       

                      In order for Creator to program/debug the kit LED2 must be SOLID ON.  Not blinking.  If LED2 is blinking at 0.5 sec rate (2Hz) then press SW3 (above LED2) once.   It should stop blinking.

                       

                      Len

                      • 8. Re: PSoC 6 101 LED problem
                        KaHe_4818731

                        Thank you, this resolved the PWM issue in the code.

                         

                        I still cannot see the device. As stated above both LED 2 and LED 4 are on constantly, pressing switch 3 seems to make the board disconnect and reconnect to the pc, and do nothing else. Switch 4 doesn't seem to do anything.

                        • 9. Re: PSoC 6 101 LED problem
                          KaHe_4818731

                          Okay I have tried to get it to work but I cannot see any debug targets.

                           

                          The LED2 on the board is solid indicating USB enumeration is successful.

                           

                          I think my mistake is that I updated the firmware of the kitprog2 to a kitprog3 device and now I don't have the drivers installed on my pc. Checking the kitprog3 user guide it recommends I have the correct KitProg3 CMSIS-DAP driver installed.

                          Under device manager it seems I only have the kitprog2 usb drivers. Where can I find the kitprog3 ones?

                          • 10. Re: PSoC 6 101 LED problem
                            KaHe_4818731

                            Okay guys I have finally done it.

                             

                            So in the kitprog3 user guide under troubleshooting the following is given that solved my problem:

                            Now after all that I can successfully program the device.

                             

                            Thank you for all the help, it is much appreciated.