5 Replies Latest reply on Nov 11, 2020 8:49 AM by RakshithM_16

    CY8CPROTO-062-4343W debug not possible

    RuGl_1600761

      Hi,

      I found a post that seems to be the same problem

       

       

       

       

       

       

        • 1. Re: CY8CPROTO-062-4343W debug not possible
          RuGl_1600761

          I found my problem. In debug there is the option programm. This is not a good idea.... Debug is Debug and not programm only... Please remove this option, it makes no sens and lead to errors ! For programming there is already a symbol. But anyhow the debug seems unstable... i get the message "auto discovery in progess" and the process is stopped ... and sometimes not ? When running the debug there is an error

          line 106 .... I already set the LED on pin 13.7. Obviously there is more to do. Is there a description for that example what to do?

          Best regards

          Rupert

          • 2. Re: CY8CPROTO-062-4343W debug not possible
            RakshithM_16

            Hello Rupert,

             

            I found my problem. In debug there is the option programm. This is not a good idea.... Debug is Debug and not programm only... Please remove this option, it makes no sens and lead to errors !

            I would recommend using the Launches in the Quick Panel to program/debug the device.

             

            Even the viodeos that are avaliable, are done with an very first version of modus.... So much differences.... very bad when you want to start with a new tool.

            Here is a tutorial on ModusToolbox 2.1 which should be similar to ModusToolbox 2.2 - Session 1: Introduction to ModusToolbox 2.x

             

            Please let me know if you have any further queries.

             

            Thanks and Regards,

            Rakshith M B

            • 3. Re: CY8CPROTO-062-4343W debug not possible
              RuGl_1600761

              Hello Rakshith,

              Thanks for the link, this helps a lot. Is there an example for USB generic HID prepared for modus 2.2?

              I searched the ..blog/2020 folder and found further session; I will also try these.

              Best regards

              Rupert

              • 4. Re: CY8CPROTO-062-4343W debug not possible
                RuGl_1600761

                Hello Rakshith,

                why is there no presentation for sessions 7,6,3,2 available ?

                best regards

                Rupert

                • 5. Re: CY8CPROTO-062-4343W debug not possible
                  RakshithM_16

                  Hi Rupert,

                   

                  Is there an example for USB generic HID prepared for modus 2.2?

                  The example is currently getting updated to ModusToolbox 2.2 and should be released soon.

                  why is there no presentation for sessions 7,6,3,2 available ?

                  Thanks for pointing this out. I think there is an issue with the links. I will get in touch with the blog owners and get this fixed.

                  But for the time being, you can find all the sessions here - Cypress Semiconductor - YouTube

                  Session 7 video is still to be uploaded and will be released soon.

                   

                  Thanks and Regards,

                  Rakshith M B