4 Replies Latest reply on Nov 12, 2020 3:10 AM by EktaN_26

    Unable to program CY8CKIT-050

    ViLa_1077171

      Hello, I am currently trying to load a sample project to my CYCKIT-050 PSoC 5 dev kit. If I try to create a new project (using PSoC Creator 4.4) I don't see PSoC 5 in the list for target devices. I only see (PSoC 3, 4, 5LP, 6, and FM0+). If I just pick PSoC 5LP and load a code example, I am unable to program the device.

       

      I am getting "This device was recognized, but PSoC Creator does not support using it at this time."

       

      Capture.PNG

       

       

      I've tried some suggestions I've found from these forums for this error: I have the latest version for Peripheral Driver Library, PSoC Programmer, and PSoC Creator according to the Update Manager. I have tried restarting my PC and different USB ports on my computer, and different USB cables as well. I am using Windows 10.

       

      From PSoC Programmer, I can Erase the flash but I can't program. Let me know if there is anything I should try or if this device is no longer supported.