2 Replies Latest reply on Nov 3, 2020 4:24 AM by TeIk_3653391

    Running 4.4 or 4.3?

    TeIk_3653391

      Hi,
      I downloaded PSoC Creator 4.4 and installed it.. or so I thought. When I launch it the splash screen shows 4.4. However the actual program that launches is 4.3.

       

      Is there something wrong in the installation or did somebody forget to update version strings?

       

       

      psoc-splash.PNG

       

      psoc-wrong-version.PNG

       

      Update manager shows 4.4 but there is a network error.

       

      psoc-update_error.PNG

        • 1. Re: Running 4.4 or 4.3?
          DheerajK_81

          Hello,

           

          I do not see this issue, I see the right version of PSoC Creator. I don't think 4.4 installed correctly because I don't see Peripheral Driver Library 3.1.3 installed in the Cypress Update Manager screenshot. It should get installed alongside PSoC Creator 4.4 ideally. 

           

          Please do the following to get it up and running again:

          1) Open run command (Win + R) and type "appwiz.cpl". This will open the Programs and Features window.

          2) Uninstall PSoC Creator 4.4

          3) Navigate to "C:\Program Files (x86)\Cypress\PSoC Creator" and delete the folder named 4.4

          4) Navigate to "C:\Users\<PC_name>\AppData\Local\Cypress Semiconductor\PSoC Creator" and delete the folder named 4.4

           

          The steps 3 and 4 needs to be done only if the uninstallation procedure wasn't able to delete these folders

           

          Once these steps are completed, reinstall PSoC Creator and it will work. Let me know how it goes

           

          Regards,

          Dheeraj

          1 of 1 people found this helpful
          • 2. Re: Running 4.4 or 4.3?
            TeIk_3653391

            Thank you, I followed the procedure and now I'm running 4.4.

             

            I used to have 4.3 in this machine but uninstalled it after installating 4.4 for the first time. Maybe installer got confused.