4 Replies Latest reply on Nov 24, 2020 1:53 AM by AH_96

    CapSense Troubleshoot

    MiGa_4589991

      I have a PSoC 6 with CapSense, making use of 2 buttons and a slider.  But a strange issue occurs when one  of the segments is pressed, it acts as one of the buttons, the button located in the opposite place, which is also the furthest element from the segment line on the PCB. I've taken a look into PSoC® 4 CapSense® Troubleshooting Guide - KBA219217, and it falls under D. Project verification which states:

       

      "If CapSense works in the tuner but doesn’t work as expected in application, the issues could be because of improper firmware flow. Refer to the example projects familiarize yourself with the CapSense Component."

       

      This is exactly what is happening, when i run the tunner, the segment from the slider works perfectly. Yet from the troubleshoot page, i could not find a proper solution to this issue, and what exactly needs to be done to solve this issue.

       

        • 1. Re: CapSense Troubleshoot
          AH_96

          Hi MiGa_4589991

           

          1. Is the button trace running close to the slider segment? It could be possible that the trace is getting touched which gives signal to the button as well.

          2. Is it possible to share your firmware for us to have a look? How are you verifying without the tuner? Please check if your logic is checking for the right sensor element.

          3. Make sure that you are scanning the sensors when CapSense is not busy.

          4. What is the signal level and SNR you are obtaining with the button and the sliders? Is the button oversensitive?

           

          Best regards,

          Hari

          • 2. Re: CapSense Troubleshoot
            MiGa_4589991

            Hey,

             

            1. No, not really, there are other running between them.

            2. I am not sure, but i don't think i can share all the firmware, but i'll check. I know because they act on LED's. each button has a specific function, and so does the slider, that's how i am sure, since the last segment is doing what the button should do, which is changing colour.

            3 Already am, followed the code examples from Cypress

            4 I can't be sure about the values, but the button is on a normal level of sensitiveness.

            • 3. Re: CapSense Troubleshoot
              AH_96

              Hi MiGa_4589991

               

              In Tuner, do you see any signal on the button sensor when the slider segment is touched? Please let us know the signal level that you are obtaining in Tuner, and the thresholds that you have set. It is recommended to set finger threshold to 80% of maximum signal, noise threshold to 40% of the maximum signal and hysteresis to 10% of the maximum signal. Note that the signal that I am referring to is the signal obtained when touching the button.

               

              Best regards,
              Hari

              • 4. Re: CapSense Troubleshoot
                AH_96

                The thread was locked due to inactivity for a long time, you can continue the discussion on the topic by opening a new thread with reference to the locked one. The continuous discussion in an inactive thread may mostly be unattended by community users.