8 Replies Latest reply on Oct 22, 2020 10:06 PM by YatheeshK_36

    Why doesn't Windows re-recognize CY7C65215 devices after COM port connections made on USB 2.0 Hub?

    miba_4627926

      Windows7

      Cypress Windows Driver Package v3.13.0.84

      Renesas Electronics USB 3.0 Host Controller Driver v3.0.23.0

      Tera Term v4.99

       

      Equipment to simulate system interconnect:

           - StarTech PEXUSB3S4V PCIe  USB 3.0 4 port Card

           - C2G 29525 2-Port USB Hub (required to simulate USB 2.0 environment)

           - Cypress CYUSBS236 DVK Board (2x)

       

      Problem:

      Re-connect of Cypress USB device on USB 2.0 hub after opening a session to all COM ports of each device results in Windows "USB Device Not Recognized" message.  Requires (minimum) restart of USB 3.0 Root Hub device to remedy.

       

      Initial connection:  USB Serial Composite Devices on USB 2.0 Hub

       

      Connection after opening & closing session to all COM ports:  Unknown Devices on USB 2.0 Hub

       

       

      Steps (repeat as necessary):

      1. Connect Cypress A (CYUSBS236 SW1)
      2. Connect to Cypress A COM port 0 (Tera Term "New Connection")
      3. Connect to Cypress A COM port 1 (Tera Term "New Connection")
      4. Connect Cypress B (CYUSBS236 SW1)
      5. Connect to Cypress B COM port 0 (Tera Term "New Connection")
      6. Connect to Cypress B COM port 1 (Tera Term "New Connection")
      7. Disconnect Cypress B COM port 1 (Tera Term "Disconnect")
      8. Disconnect Cypress B COM port 0 (Tera Term "Disconnect")
      9. Disconnect Cypress B (CYUSBS236 SW1)
      10. Disconnect Cypress A COM port 1 (Tera Term "Disconnect")
      11. Disconnect Cypress A COM port 0 (Tera Term "Disconnect")
      12. Disconnect Cypress A (CYUSBS236 SW1)