1 Reply Latest reply on Oct 19, 2020 12:30 AM by SananyaM_56

    CY4500 EZ-PD firmware and Linux protocol analyzer utility

    anai_3018681

      I've tried to connect my EZ-PD dongle to the Linux tool and I get an error

       

      "Firmware upgrade is required. Please update the firmware on a windows machine"

       

      I downloaded the latest windows utility and programmed the firmware in there. The firmware version shows 1.0.0.32

       

      The Linux tool still refuses to connect to it. What firmware version do I need to use the Linux tool ?

        • 1. Re: CY4500 EZ-PD firmware and Linux protocol analyzer utility
          SananyaM_56

          Hello,

           

          Please try updating the firmware present with the latest Windows installer of the utility. The firmware update tool and the 2.0.7.0 version of firmware would be present at the path- <install directory>\Cypress\EZ-PD Protocol Analyzer Utility\Firmware_Update_Tool

          After the update is completed, please check if the utility on Linux is able to connect to it and display the recorded traffic.

           

          Best Regards,
          Sananya