5 Replies Latest reply on Oct 15, 2020 12:37 PM by StNu_1610991

    Creator 4.3 Error: unknown type name 'cy_stc_ble_srvr_char_info_t'

    StNu_1610991

      A BLE component is being used in an application and during the PSOC Creator 4.3 compile the above error keeps being generated.  It seems to be a result of the symbol CY_BLE_MODE_PROFILE not being properly defined.  The problem is that both symbols are generated by Creator and as far as I know I have no control over how this is done. 

       

      The same BLE component with the same configuration settings is also being used in another application and that application compiles and runs fine without the error.

       

      I originally added the BLE into the problem application by copying the BLE component from the working application and pasting it into the problem application.  When the error appeared, the BLE component and generated code were erased and a new BLE component was added and configured manually to be the same as the one in the running application.  The error still came up.   Right now I am at a loss as to how to get rid of this error.

       

      Has anyone seen this type of problem before and how was it resolved?

        • 1. Re: Creator 4.3 Error: unknown type name 'cy_stc_ble_srvr_char_info_t'
          PradiptaB_11

          Hi,

           

          Can you send us across your creator project. We need to check and reproduce the error to debug it. It seems as some header files are missing or some text has been deleted from the generated code. Cannot say this for sure as will need to check the project before commenting with surety.

           

          Thanks,

          Pradipta.

          • 2. Re: Creator 4.3 Error: unknown type name 'cy_stc_ble_srvr_char_info_t'
            StNu_1610991

            Thanks for the response.  The project is too large and proprietary to send it as is.  I will subset it to a smaller project where the problem still shows.  I will then send that project.

             

            The project worked very well before trying to add the BLE component to connect it to a phone.  Since this error appeared I have not had any successful compiles.

             

            There seem to be a lot of problems associated with the BLE component.  In a separate project a BLE running in CM4 worked successfully.  Then I configured it to run on CM0p and I could not get it to run again because of undefined creator generated symbols.  Also, despite the fact that it was moved to CM0p, it still put the BLE_bless_isr into CM4.  When that was unchecked and the CM0p interrupt was checked, it continued to produce an error saying the BLE_bless_isr needed to be on CM0p.  I had to give up trying to move to CM0p and left the project with BLE on CM4.

             

            Am I maybe missing something about controlling the BLE configuration?

            • 3. Re: Creator 4.3 Error: unknown type name 'cy_stc_ble_srvr_char_info_t'
              StNu_1610991

              I have not yet been able to reproduce the problem first reported.  However, I have a second similar project which also needs blue tooth.  In building this project I experimented with putting the BLE component first into TopDesign.cysch and then adding other components.  When compiled, this did NOT have the problem seen in the original project.  However, I am not yet at the point of testing this second project.

               

              I will try doing the same on the original project: remove all components, put in the BLE component first, make sure BLE_bless_isr is in CM0p and then add the rest of the components.

               

              Another test was built to check for the BLE in CM0p.  A blank project was prepared and a BLE component was added and forced to CM0p (the default).  When compiled it produced an error saying that the BLEbless_isr must be in CM0p.  The generated code had put it into CM4.  Attached is bundle for this.

              • 4. Re: Creator 4.3 Error: unknown type name 'cy_stc_ble_srvr_char_info_t'
                StNu_1610991

                More attempts were made to get around this problem but all so far unsuccessful.  Another type of error was produced on a compile.  The output was:

                 

                "Generated_Source\PSoC6\BLE.c: In function 'Cy_BLE_Start':

                Generated_Source\PSoC6\BLE.c:126:22: error: 'cy_stc_ble_config_t {aka struct <anonymous>}' has no member named 'callbackFunc'

                        cy_ble_config.callbackFunc = callbackFunc;

                                      ^

                The command 'arm-none-eabi-gcc.exe' failed with exit code '1'.

                --------------- Build Failed: 10/14/2020 10:00:30 ---------------"

                 

                 

                The bundle generated after this compile is attached.  Proprietary source code was removed from the bundle but you should be able to see what Creator 4.3 generated.

                • 5. Re: Creator 4.3 Error: unknown type name 'cy_stc_ble_srvr_char_info_t'
                  StNu_1610991

                  I have tried different ways of adding the BLE component and configuring it but they all end up with similar compile errors.  The BLE was also moved to CM4 with the same results.

                   

                  The compile errors involve only symbols and modules generated by the Creator itself so they must be generation errors.

                   

                  Is there a modification that could be made to the generated header files to get around these problems?