5 Replies Latest reply on Oct 8, 2020 3:58 AM by RakshithM_16

    Project Creator: No New projects found

    StSc_4454611

      Hi,

       

      I am running ModusTollbox 2.2 on ubuntu (actually within a docker container, for reasons).

       

      Everything works fine on the command line:

       

      root@5a35386d6998:~# ModusToolbox/tools_2.2/project-creator/project-creator-cli --list-apps CY8CKIT-062-BLE

      Getting manifest...

      Processing super-manifest https://github.com/cypresssemiconductorco/mtb-super-manifest/raw/v2.X/mtb-super-manifest-fv2.xml...

      - Middleware ota commit latest-v1.X requires library mcuboot commit v1.5.0-cypress which is not present in the manifest data.

      - Middleware ota commit release-v1.2.0 requires library mcuboot commit v1.5.0-cypress which is not present in the manifest data.

      Successfully acquired the information.

      List of template applications supported by the board "CY8CKIT-062-BLE":

      mtb-example-psoc6-ble-battery-level-freertos

      mtb-example-psoc6-ble-capsense-tuner-client

      mtb-example-psoc6-ble-capsense-tuner-server

      mtb-example-psoc6-ble-findme

      mtb-example-psoc6-ble-throughput-freertos

      mtb-example-psoc6-capsense-buttons-slider

      ...

       

      but when trying to open the project creator from ModusToolbox (eclipse), I cannot see any available project:

       

      the console shows:

       

      Opening project creator from /root/ModusToolbox/tools_2.2/project-creator/project-creator

      No new projects found.

      Done.

       

      The logfile shows:

       

      2020/10/06 13:10:55 DEBUG: Translated tool CY_TOOL_project-creator_EXE => project-creator/project-creator.

      2020/10/06 13:10:55 DEBUG: Tools path resolved with project-creator/project-creator is CyRsltOrErr{Value: /root/ModusToolbox/tools_2.2/project-creator/project-creator}.

      2020/10/06 13:10:55 DEBUG: getToolsPath returning: CyRsltOrErr{Value: /root/ModusToolbox/tools_2.2/project-creator/project-creator}.

      2020/10/06 13:10:55 INFO: Opening project creator from /root/ModusToolbox/tools_2.2/project-creator/project-creator

       

      2020/10/06 13:10:56 INFO: Project Creator raw output:

      2020/10/06 13:10:56 INFO: Project Creator output (1/1): >><<

      2020/10/06 13:10:56 WARNING: No new projects found.

       

      2020/10/06 13:10:56 INFO: Done.

       

      Actually same behavior is observed with previous versions ...

       

      What could be the reason for that ? Any way to enable more verbose logging ?

       

      Any hints apreciated.

       

      Best Regards

      Stephan

        • 1. Re: Project Creator: No New projects found
          RakshithM_16

          Hi Stephan,

           

          Can you please confirm that all the steps mentioned in the ModusToolbox Installation Guide were successful for you? Also, did you change the default installation directory in which ModusToolbox is installed?

           

          Regards,

          Rakshith

          • 2. Re: Project Creator: No New projects found
            StSc_4454611

            Hi,

             

            everything in the installation works fine,

             

            only I omit these three steps, as I am running in a container and I have no access to physical USB ports or attached debuggers.

             

            OpenOCD: <user_home>/ModusToolbox/tools_2.2/openocd/udev_rules/install_rules.sh

            WICED Bluetooth Boards: <user_home>/ModusToolbox/tools_2.2/driver_media/install_rules.sh

            Firmware Loader: <user_home>/ModusToolbox/tools_2.2/fw-loader/udev_rules/install_rules.sh

             

            Everything works fine:

            - I can create a project using project-creator-cli

            - When I import the created project into a ModusToolbox workspace everything is fine

            - I can build from within the IDE

            - I can debug a remote target through Segger Debug Server

             

            Just I cannot use the project creator from within the IDE ... no errors or warnings ... just "No new projects found"

             

            Best Regards

            Stephan

            • 3. Re: Project Creator: No New projects found
              RakshithM_16

              Hi Stephan,

               

              I have forwarded your query to the internal team for assistance. Can you please provide a few more details?

               

              1. What version of Ubuntu are you using? Please provide the output from the command - lsb_release -a

              2. Please run the command - printenv and share the output.

              3. Can you click on New Application in Eclipse IDE and share a screenshot of this?

              4. Are you able to run the Project Creator GUI standalone without using Eclipse IDE?

              5. Can you please let us know how you are running Eclipse IDE from within a Docker?

              6. Also, are you running project-creator-cli from a terminal app in the Linux GUI environment or directly (eg., by SSH into the Docker image)?

               

              Thanks and Regards,

              Rakshith M B

              • 4. Re: Project Creator: No New projects found
                StSc_4454611

                Hi Rakhshith,

                 

                when trying to run the project creator stand alone (which I was not aware, that it is possible), it gave me a kind of meaningful error message:

                 

                root@543df700c930:/# ~/ModusToolbox/tools_2.2/project-creator/bin/project-creator

                qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.

                This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

                 

                Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.

                 

                searching the web led me to this post:

                 

                https://stackoverflow.com/questions/57362015/how-to-fix-could-not-load-the-qt-platform-plugin-xcb-in-even-though-it-was

                 

                which suggests to

                 

                apt-get install libxkbcommon-x11-0

                 

                This solved the issue for me.

                 

                Thanks for your help

                Stephan

                • 5. Re: Project Creator: No New projects found
                  RakshithM_16

                  Hi Stephan,

                   

                  Glad your issue is resolved

                  Thank you for providing an update on this thread!

                   

                  Best regards,

                  Rakshith